mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit PCF8574


Autor: Christoph Krikl (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

ich hab da ein kleines Problem mit meinem PCF8574, im allgemeinen leuft
es eigentlich ganz gut, das setzen von Portzustängen geht ohne Probleme,
nur beim lesen happerts ein bissi, eigentlich geht das auch,
zumindestens bei den PORTS 0-6, sobald ich jedoch den Port 7 auf low
ziehe und dann das register auslese erhallte ich den richtigen wert,
wenn ich jetzt ein zweites mal versuche das register auszulesen, bleibt
er in der schleife beim warten auf das acknowledge nach dem senden der
start condition hängen.

kann mir jemand helfen was ich falsch machen, ich hab ja zuerst gedacht
das der chip vielleicht was hat, habs aber schon mit 3 verschieden
ausprobliert ist jeweis das selbe

danke im vorraus
Christoph

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.