mikrocontroller.net

Forum: Compiler & IDEs Simplicity Studio V4 Debugger Einstellungsproblem


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Remu (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen
seit gestern habe ich das Problem, dass wenn ich meinen Code debuggen 
will, alle Breakpoints übersprungen werden und der Debugger nicht wie 
üblich beim Main startet sondern losläuft. Dies obwohl ich den 
Startbutton noch nicht gedrückt habe.

Sobald ich den Debugprozess pausiere, scheint der Prozessor in einem 
Loop oder undefinierten Zustand zu sein, denn ich kann in diesem Moment 
nicht weiterspringen oder sonst etwas machen. Wenn ich über die Software 
einen Reset durchführe, passiert wieder das Selbe wie oben beschrieben.

Ich verwende Simplicity Studio V4 und das Bluetoothmodul BGM113 mit dem 
EFR32 darauf. Das Programm übertrage ich mit dem SEGGER J-Link Edu mini.

Das Bluetoothmodul und Setup scheint zu funktonieren, denn wenn ich 
einen Beispielcode für einen EFM32PG1B lade und diesen laufen lasse, 
kann ich diesen problemlos debuggen.

Deshalb denke ich, dass etwas mit den Einstellungen für den Debugger 
nicht stimmt. Ich weiss jedoch nicht was ich ändern muss. Ich habe 
meinen abgespeckten und den funktionierenden Code angehängt.

Ich bin über jede Hilfe dankbar, welche mich weiterbringt, damit ich 
meinen Code wieder debuggen kann.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.