mikrocontroller.net

Forum: Platinen KICAD Probleme mit 3D Darstellung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Kevin B. (bucki)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Gemeinde,

ich habe ein Problem mit der 3D-Darstellung bei Kicad. Dazu habe ich mal 
ein Foto angehangen. Der allgemeine Pfad stimmt auf alle Fälle. Nun 
referenziert Kicad irgendwie automatisch auf alle Ordner mit der 
Mehrzahl "s", z.B. Resistors. Diese existieren aber gar nicht, wodurch 
eine 3D Darstellung fehlschlägt. Erst durch das hinzufügen des richtigen 
Ordners kann ich das Modell des jeweiligen BE sehen.

Weiß jemand wie ich standardmäßig diesen Pfad/Verweis ändern kann? Es 
wäre mehr als lästig für jedes Bauteil erst noch die richtige 3D Shape 
raussuchen zu müssen... Über Hilfe wäre ich sehr dankbar!

VG
Bucki

Autor: Thomas P. (pointhi)
Datum:

Bewertung
1 lesenswert
nicht lesenswert
Das was du siehst passiert wenn du die v4 Bauteilbibliothek mit der v5 
3D-Bibliothek mischt.

Ich vermute mal, dass du KiCad 5 benutzt, die Bibliothek jedoch noch das 
GitHub Plugin verwendet was v4 standard war. Schau dir mal den Footprint 
Library Manager an was da derzeit drinnen steht.

Aktuelle Bauteilbibliothek: https://github.com/KiCad/kicad-footprints
Aktuelle 3D-Bibliothek: https://github.com/KiCad/kicad-packages3D

Autor: Kevin B. (bucki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Okay, habe das Problem nach stundenlanger Suche dann doch beheben 
können. Es lag wohl ein Problem mit dem KICAD Github Repo vor, dieses 
hatte andere Benamungen wie KiCAD intern. Ich habe also alle 3D Files 
von GITHUB auf KICAD umgestellt und die Benamung geändert, jetzt kann 
KiCAD wieder 3D Dateien zu den Footprints linken.

Thread kann also geschlossen werden. :)

VG
Bucki

Autor: Kevin B. (bucki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ah zu spät gesehen, haha. Genau wie Thomas schrieb, die Repo verträgt 
sich nicht so ganz mit KiCAD 5. Dir vielen dank, auch wenn ich's zu spät 
gelesen habe. ^^

Grüße
Bucki

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.