mikrocontroller.net

Forum: Platinen KiCad : Probleme mit Schaltplan-Editor


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Hubert J. (hubert_j)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich arbeite mich gerade in KiCad Version 5.1.2 ein. Im Schaltplan-Editor 
kann ich die Bauteile ohne Probleme auswählen und einfügen.
Aber beim Elektrischen Verbindungen hinzufügen funktioniert das nicht 
richtig. Mit dem Mauszeiger gehe ich auf einen Kontakt, ziehe die 
Verbindung zu einem anderen Kontakt und mache einen Doppelklick. Dann 
erscheint mir bei den beiden verbundenen Kontakten entweder ein 
Knotenpunkt, obwohl da gar kein Knoten sein soll, oder ein Kreis mit 
einem Rechteck, die nicht exakt übereinstimmen.
Ich muss also auf maximalen Zoom und dann die Verbindungen exakt 
positionieren, sonst tritt der Mangel wieder auf.
In den Einführungsvideos bei YouTube sieht das alles ganz einfach aus. 
Muss ich vielleicht etwas im Setup einstellen?
Danke für eure Mühe
Gruß
Hubert

Autor: SMD (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, du musst nichts einstellen, es ist viel einfacher:
Nicht ziehen, sondern am Anfang einmal klicken und einmal am Ende. Du 
kannst auch noch zwischendurch klicken, um Knicke zu erzeugen.

Autor: Hubert J. (hubert_j)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
vielen Dank für die schnelle Antwort. Leider hat dein Tipp nicht 
geholfen, siehe Anhang.
Ich klicke einmal auf den ersten Kontakt (lasse die Maustaste los), dann 
ziehe ich die Verbindung zum zweiten Kontakt. Dort beende ich die 
Verbindung mit einem Doppelklick.
Das Ergebnis seht ihr im Anhang.

Gruß
Hubert

Autor: Thomas W. (goaty)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ohne Doppelklick ? Ich muß nur am Anfang einmal, dann an 
Knicken und einmal am Ende Klicken.

Autor: Gerald B. (geraldb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du sollst doch nicht doppelt klicken.

Überprüfe auch, ob das eingestellte Raster zu den Bauteilen paßt.

Autor: Hubert J. (hubert_j)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich am Ende nur einmal Klicke, dann macht die Verbindung einen 
Knick und will weitergeführt werden. Nur mit einem Doppelklick beende 
ich die aktuelle Verbindung.
Gruß
Hubert

Autor: Hubert J. (hubert_j)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit der Rastereinstellung ist ein Problem. Normal bräuchte ich ein 
Raster von 2,54mm. Dieses Raster kann ich aber nicht einstellen. 1, 2,5 
10 usw. habe ich zur Auswahl.

Autor: Thomas W. (goaty)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist ein Scherz oder ? Ach ja, Freitag.

Falls nicht. 2.54mm oder 100mil sind nur im Platinenlayout relevant, 
nicht im Schaltplan...

Autor: Hubert J. (hubert_j)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was soll ich im Raster einstellen?

: Bearbeitet durch User
Autor: Sebastian S. (amateur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Hubert Jott
Ich kenne mich zwar nicht mit KiCad aus, aber rührt Dein Problem 
vielleicht daher, dass Du nicht die Einstellung für Millimeter 
verwendest, sondern irgendetwas Usanesisches bzw. was von der Insel?

: Bearbeitet durch User
Autor: Thomas W. (goaty)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh sorry, mein Fehler, ist Freitag.

Es ist tatsächlich in inch/mil einzustellen. Bitte um Vergebung.

Keine Ahnung, bei mir sind 50mil eingestellt.

Beitrag #5934179 wurde vom Autor gelöscht.
Autor: Thomas W. (goaty)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Konnte das Problem gerade nachvollziehen. Wenn ich das Raster auf 2,54mm 
stelle, so habe ich bei einem Widerstand, den ich einfüge und drehe, das 
Problem, daß ich  die Leitung nicht an den Endpunkt am Widerstand 
anschließen kann.
Am Besten das Raster wieder auf 1.27mm stellen.

Autor: Hubert J. (hubert_j)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie stellt du ein Raster von 1,27mm ein? Ich habe doch, wie schon 
beschrieben die Auswahl 1, 2, 5, 10 usw.
Danke
Hubert

Autor: Chris K. (deadeye5589)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
50 mil oder 1,27 mm ist das Standard Grid in KiCad. Damit sollte es 
eigentlich keine Probleme geben. Die Bauteile aus der KiCad Lib alle für 
dieses Raster gemacht. Wenn du das Bauteil aus einer anderen Quelle 
hast, oder es gar selber gezeichnet ist, kann es natürlich sein, dass 
die Anschlüsse nicht auf dem Raster liegen.

Ansonsten geht es wie beschrieben. Ein einfacher klick auf den ersten 
Anschluss. Leiterbahn hängt an der Maus. Ein einfacher klick auf das 
zweite Pad. Fertig

Autor: Thomas W. (goaty)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ansicht -> Rastereinstellungen -> 50mils auswählen

Autor: Hubert J. (hubert_j)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich nur nur die Möglichkeit mm oder inch.

Hubert

Autor: Chris K. (deadeye5589)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Rater. Rechtsklick in freie Fläche und dann siehe Bild

Autor: Thomas W. (goaty)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die zwei Knöppe oben links stellen nur um in welcher Einheit angezeigt 
wird. z.B. die Anzeige unten rechts in der Statusleiste.

Autor: Hubert J. (hubert_j)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ihr alle,

habt vielen Dank, ihr habt mein Wochenende gerettet. Wenn ich jetzt 
meine Bauteile nach dem neuen Raster ausrichte, kann ich wunderbar meine 
Verbindungen ziehen.

Ich wünsche euch ein schönes Wochenende.

Nochmals vielen Dank

Gruß
Hubert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.