mikrocontroller.net

Forum: PC-Programmierung Frage an react Spezialisten


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Frank L. (Firma: Flk Consulting UG) (flk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich arbeite mich gerade in react und einige seiner Spezialitäten ein.

Jetzt stoße ich auf ein Problem, dass ich nicht nachvollziehen kann.

Das folgende Beispiel kann ich compilieren:
const {components} = {component: "test", title: "" };

Das zweite Beispiel lässt sich einfach nicht compilieren:
const {components, ...rest} = {component: "test", title: "" };

Ich erhalte in diesem Fall die Fehlermeldung:
TypeError: Cannot read property 'forEach' of undefined

Ich habe ehrlich keine Ahnung mehr, wo ich noch suchen soll, bzw. was 
hier falsch läuft. In CodeSandbox funktioniert das Beispiel einwandfrei 
lässt sich also fehlerfrei compilieren.

Hat jemand einen Tipp für mich?

hier noch meine package.json
{
  "name": "inventur",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "devextreme": "19.1-stable",
    "devextreme-react": "19.1-stable",
    "devextreme-themebuilder": "19.1-stable",
    "node-sass": "^4.11.0",
    "react": "^16.10.1",
    "react-app-polyfill": "^1.0.0",
    "react-dom": "^16.10.1",
    "react-router-dom": "^5.0.0",
    "react-scripts": "3.1.2",
    "typescript": "3.3.3"
  },
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject",
    "build-themes": "devextreme build",
    "postinstall": "npm run build-themes"
  },
  "eslintConfig": {
    "extends": "react-app"
  },
  "browserslist": {
    "production": [
      ">0.2%",
      "not dead",
      "not op_mini all"
    ],
    "development": [
      "last 1 chrome version",
      "last 1 firefox version",
      "last 1 safari version"
    ]
  },
  "devDependencies": {
    "@babel/cli": "^7.6.2",
    "@babel/core": "^7.6.2",
    "@babel/plugin-proposal-object-rest-spread": "^7.6.2",
    "babel-preset-env": "^1.7.0",
    "babel-preset-react": "^6.24.1",
    "babel-preset-stage-2": "^6.24.1",
    "devextreme-cli": "1.1.6"
  }
}

Gruß
Frank

: Bearbeitet durch User
Autor: Kein react spezi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
https://github.com/facebook/create-react-app/issues/7753

Also entweder upgraden, oder downgraden.

Autor: Frank L. (Firma: Flk Consulting UG) (flk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke,
Du bist heute mein Held :-)

Gruß
Frank

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.