mikrocontroller.net

Forum: Compiler & IDEs STM32F407 HardFault bei float Zuweisung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Andre (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Moin,

die folgende Zuweisung verursacht stets einen Hardfault. Es ist ein 
STM32F407VGT6.
int16_t s16Temp = 0;
fResult = (float)s16Temp;

Mit einer Konstanten funktoniert es:
int16_t s16Temp = 0;
fResult = 12.34;

In den Projekteinstellungen ist -mfloat-abi=hard gesetzt.

Was kann das sein?

Danke für eure Tips!

von Andre (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Das kann gelöscht werden danke! Falsches Forum!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.