Forum: Mikrocontroller und Digitale Elektronik STM32F303: Abhängigkeiten zw Pins und Interrupts


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von har (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo liebes Forum,

ich programmiere einen STM32F303 und verwende von STMicroelectronics die 
stm32_library (STM32F30x_StdPeriph_Driver).
Die Pins GPIOC 13, 14 und 15 sind bei mir Outputs. Die Initialisierung 
dafür sieht folgendermaßen aus:
1
Init_GPIOC(&GPIOx_InitStruct);
2
3
void Init_GPIOC(GPIO_InitTypeDef* pGPIOx_InitStruct)
4
{
5
    // enable peripheral clock for GPIOC
6
    RCC->AHBENR |= RCC_AHBPeriph_GPIOC;
7
8
    // reset all GPIOs to inputs
9
    RCC->AHBRSTR |=  RCC_AHBPeriph_GPIOC;                                       // reset port C
10
    RCC->AHBRSTR &= ~RCC_AHBPeriph_GPIOC;
11
        pGPIOx_InitStruct->GPIO_Pin   = (GPIO_Pin_13 | GPIO_Pin_14 | GPIO_Pin_15);
12
        pGPIOx_InitStruct->GPIO_Mode  = GPIO_Mode_OUT;
13
        pGPIOx_InitStruct->GPIO_Speed = GPIO_Speed_Level_1;                         
14
        pGPIOx_InitStruct->GPIO_OType = GPIO_OType_PP;                              
15
        pGPIOx_InitStruct->GPIO_PuPd  = GPIO_PuPd_NOPULL ;
16
17
        GPIO_Init(GPIOC, pGPIOx_InitStruct);
18
}

Nach der Initialisierung setze ich die Outputs dieser Pins (GPIO13, 14, 
15) Low. Das funktioniert auch!
Sobald ich diverse Interrupts einschalte, gehen die Leitungen ungewollt 
High!

Und zwar habe ich folgende seltsame Abhängigkeiten:
Die Zeile
1
 NVIC_EnableIRQ(EXTI4_IRQn);     // EXTI 4 interrupt vector enabled
 setzt den GPIOC Pin 15 wieder High!


Zeile
1
 NVIC_EnableIRQ( USART1_IRQn );                                              // USART1 interrupt vector enabled
 setzt GPIOC Pin 13 wieder High!


Zeile
1
 NVIC_EnableIRQ(TIM7_IRQn);                                              // TIM7 Interrupt vector enabled
 setzt GPIOC Pin 14 wieder High!


Offensichtlich gibt es eine gewisse Abhängigkeit von Pin 15 mit 
EXTI4-Interrupt; Pin 13 mit USART1-Interrupt; Pin 14 mit 
Timer7-Interrupt!!

Habt ihr Ideen, warum das passiert? Warum habe ich diese Abhängigkeiten 
mit den Interrupts? Wie kann ich dieses Problem lösen?

Bin für jeden Hinweis dankbar!

Liebe Grüße!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.