mikrocontroller.net

Forum: PC-Programmierung System.IO.Ports.SerialPort?


Autor: Peter Z. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe heute mal ein bißchen mit der SerialPort Klasse rumgespielt.
Habe verschiedene Baudraten und COM-Ports initialisiert.
Nur bei der Einstellung Baudrate:76800 und COM-Port:COM1
lies sich die Schnittstelle nicht öffnen. Wenn ich aber die
Baudrate verändert hab z.B. auf 115200 gings wieder. Auch mit einen
anderen Port und 76800 ging es!
Hab nicht ganz verstanden wo der Fehler lag...
Jemand eine Idee?

Autor: Μαtthias W. (matthias) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

eben diese Schnittstelle scheint eine Baudrate von 76800 nicht zu
unterstützen.

Matthias

Autor: Peter Z. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aha, sehr interessant...
Wo ist denn das dokumentiert??
Kann man das irgendwo nachlesen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.