mikrocontroller.net

Forum: Digitale Signalverarbeitung / DSP Problem mit Befehl "fftfilt"


Autor: anabolik (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo leute,

beim anwenden des befehls "fftfilt" bekomme ich immer wieder unsinn.
z.b. beim klicken auf "PushButton" (m-file im anhang. keine viren
oder so was!!) erklingt die sounddatei verzerrt wenn ich die untere
schleife verwende (diese soll erlauben den Slider während des
Abspielens bewegen zu können. Dabei sollen gleichzeitig Veränderungen
in der Lautstärke wahrnembar sein.). wenn man in dieser schleife "k"
z.b. auf 40 verkleinert, so kommt eine fehlermeldung "Unable to write
into sound device"
was mache ich falsch???
keine angst vor dem quellcode :). es geht nur um den befehl "fftfilt"

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.