mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik I2C - SDA und Portpin ATMEGA88


Autor: ecslowhand (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe ein kleines Problem, sehe wahrscheinlich den Wald vor lauter Bäumen
mal wieder nicht:

Ich betreibe einen ATMEGA88 und benutze den I2C-Bus.
PC4(SDA) hat einen PullUp(10k). PC4 ist dabei mit PC1 verbunden, sobald
der "externe, steckbare" I2C-Slave mit der Schaltung verbunden ist,
dabei ist PC1 als Eingang konfiguriert, tristate.

Leider zieht PC4(SDA) dann nicht mehr richtig auf LOW. Trenne ich PC1,
funktioniert alles wunderbar.

Hat jemand einen Tipp ???

Wie gesagt: DDC1 = 0, PORTC1 = 0 !

Lg EC

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.