mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Trotz Umprogrammierung immer selber Effekt.


Autor: Peter P. (ox5o)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,


also egal welches Programm ich auf meinen Chip (Atmel Mega16) spiele,
es passiert immer nur dasselbe: eine LED auf dem Evoluationsboard
blinkt sehr schwach..

Cache löschen, etc, Systemrestart...alles probiert..

Am Anfang ging alles Einwandfrei, habe 2 Beispiel-Codes von Bascom
angepasst und es ging alles nach Plan..also Summer ansteuern und LED
alternierend blinken lassen...


Jetzt meine Frage: An was kann das liegen?

Habe ich als Anfänger was vergessen oder falsch gemacht?

Ich werd noch wahnsinnig... -.-




Peter

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Womit programmierst du?
Ich bin mal bei Ponyprog reingefallen, weil ich nicht AutoProgramm
(erase and programm) ausgeführt hab sondern nur programm. Hatte einen
ähnlichen effekt.

Autor: Winfried (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei AVR-Studio bin ich auch schon einige male darauf reingefallen: Wenn
man ein neues Projekt wählt, wird beim proggen trotzdem die Hex-Datei
des alten Projektes genommen und gebrannt. Dort muss man noch manuell
die Hex-Datei neu einstellen. Total bescheuert. Ich bin doch nicht in
Projekt X, um dann Projekt Y zu brennen.

Autor: Peter P. (ox5o)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey danke.

Im Nachhinein denke ich, dass ich auch diesen tollen Fallen in der
Software zum Opfer gefallen bin.
Ich nutze wechselnd Bascom, AVR-Studio und Pony..

Aber ich habe das Problem gleich direkt mit einer neuen Platine und
Format c: gelöst ;-)



Dankeschön :-)

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Winfried:
Das liegt wohl daran, dass das Prog-Programm eigenständig ist und nur
aufgerufen wird. Du kannst jedoch auch auswählen "use current
simulation data" oder so (falls du das Programm gerade Simmulierst)
dann hast du das Problem nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.