mikrocontroller.net

Forum: Haus & Smart Home 'NULL' an VT_R4


Autor: Rüdiger Bartsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe da ein Problem mit einem BACNet-Server von MBS und einem
Client-Control von Softing :

nach dem Setzen eines Wertes in 'present-value'benötigt der
BACNet-Server noch ein Rücksetzen des 'priority-array' mit 'NULL'.

Dies soll durch Beschreiben des 'present-value' mit 'vt_null'
geschehen.

Mit dem Softing-Client bekomme ich aber nur eine '0' geschrieben,
wodurch das 'priority-array' nicht zurückgesetzt wird.

Ist es generell möglich, ein Attribut vom Typ VT_R4 mit einem VT_NULL
zu beschreiben ?

Und schafft der Softing-Client das überhaupt, wenn er sich - vermutlich
- vom Server den Datentyp VT_R4 nennen lässt ?


Hoffentlich kann mir jemand einen Tip geben.

Danke im Voraus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.