Forum: Compiler & IDEs STM32CubeIDE Projekt kennt kein target 'all'


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christoph K. (chriskuku)


Lesenswert?

Habe mir irgendwie ein Projekt "verbogen". Hatte einen Import eines 
Projektes gemacht (.project). When ich versuche, das Projekt zu bauen 
(Build), bekomme ich
1
ake all 
2
make: *** No rule to make target `all'.  Stop.
3
"make all" terminated with exit code 2. Build might be incomplete.
4
5
10:35:43 Build Failed. 1 errors, 0 warnings. (took 128ms)

EDIT: Gehe ich ins Verzeichnis Debug und führe dort (Terminal) "make 
all" aus, funktioniert's wunderbar. Irgendwie scheint das Target nicht 
richtig eingestellt zu sein.

: Bearbeitet durch User
von aufgewacht (Gast)


Lesenswert?

Schön dass du uns so früh am Morgen schon deinen Kummer mitteilst.

von pegel (Gast)


Lesenswert?

rechter Mausklick auf das Projekt, dann Index -> ...
was meinen die dort vorhandenen Funktionen dazu?

von J. S. (jojos)


Lesenswert?

Oder den Builder von internal auf extern umgestellt? Bin aber gerade 
nicht sicher ob das diese Fehlermeldung produziert.

von Christoph K. (chriskuku)


Lesenswert?

J. S. schrieb:
> Oder den Builder von internal auf extern umgestellt? Bin aber gerade
> nicht sicher ob das diese Fehlermeldung produziert.

Danke. Ich leide immer noch unter den Folgen des mal eben kurzen 
Ausprobierens von EGit. Da ist immer noch der Pfad ~/git/repository 
verdrahtet.

Vielleicht mache ich eine Cube Neuinstallation.

von J. S. (jojos)


Lesenswert?

Hast du das Projekt zurück kopiert? Besser ist das per Import wieder an 
die alte Stelle zu kopieren.

von Christoph K. (chriskuku)


Angehängte Dateien:

Lesenswert?

J. S. schrieb:
> Hast du das Projekt zurück kopiert? Besser ist das per Import wieder an
> die alte Stelle zu kopieren.

Habe es auch per Import probiert. Aber Cube hat sich irgendwo mein 
~/git/repository so eingebrannt, daß ich das nicht loswerde.

Hab's gerade noch mal gelöscht und neu importiert. Jetzt bin ich wieder 
am Ausgangspunkt dieses Threads. Aber immerhin, reproduzierbar.

@jojos: wo stellt man nochmal den Builder um (internal/external?)
Bei Properties sehe ich "Builders", habe da zwei gelistet, CDT (an 
erster Stelle) und Scanner Configuration Builder.
Sehe nur keine Umstellmöglichkeit.

OK, habe was gefunden, sieht aber nicht so aus, als sei das verstellt. 
(s. Bild)

: Bearbeitet durch User
von J. S. (jojos)


Angehängte Dateien:

Lesenswert?

habe mich jetzt erst an den Rechner getraut...
Das sieht bei mir änhnlich aus, aber 'generate Makefile auto' ist bei 
mir an. So erwartet der Builder ein wie auch immer erstelltes in dem 
Pfad der darunter eingestellt wird.
Bei 'auto' ist die Build location irrelevant bzw. wird dann das 
Ausgabeverzeichnis Debug/Release benutzt.

: Bearbeitet durch User
von Christoph K. (chriskuku)


Lesenswert?

Bei mir kann ich "Makefile generation" gar nicht beeinflussen. 
Ausgegraut.

von J. S. (jojos)


Lesenswert?

das ist bei mir so wenn ich den internal Builder anwähle.
Wenn ich das falsch einstelle, dann kommt auch deine Fehlermeldung. Es 
liegt also sicher an der Build Location, das erklärt auch warum das make 
manuell im Terminal funktioniert.

: Bearbeitet durch User
von J. S. (jojos)


Angehängte Dateien:

Lesenswert?

hier ist noch die Einstellung vom Build Environment.
CWD ist unterschiedlich beim in ~/git verschobenen Projekt und nicht 
verschobenen Projekt. Vielleicht ist das beim zurückschieben nicht 
angepasst worden.

: Bearbeitet durch User
von Christoph K. (chriskuku)


Lesenswert?

Auf welchem Wege kommt man denn zur Einstellung "internal Builder"?

von J. S. (jojos)


Lesenswert?

Christoph K. schrieb:
> Auf welchem Wege kommt man denn zur Einstellung "internal
> Builder"?

in der Drop Down Box auswählen?
gut, die ist bei dir auch grau/disabled wie es aussieht. Also doch das 
CDT kaputt? Sieht merkwürdig aus, ist das Hammer Symbol noch in der 
Toolbar oben? Wenn das weg ist, dann hilft am einfachsten eine 
Neuinstallation.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.