mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Arm Cross Development: OpenOCD - error 193


Autor: Stephan S. (laglisse)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo!

infos:
1. arm cross development paket nach jim lynch
2. amontec jaygkey
3. mcb2140-board mit lpc2148

problem:
ich versuche gerade den openocd unter eclipse zum laufen zu bekommen und 
erhalte folgende fehlermeldung (->screenshot):

Error creating process /cygdrive/d/Eigene 
Dateien/workspace/blinky_disco/blinky_disco.out, (error 193).

kann mir da jemand weiterhelfen?

grüße,
stephan

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Möglicherweise passt dem ganzen das Leerzeichen im Pfad nicht ?
Würde mal einen einfachen Ordner in der Verzeichnisstrucktur direkt 
unter D:\test probieren..... ????

Autor: Stephan S. (laglisse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab's getestet und auf d:\workspace... gewechselt -> gleiches problem 
ohne leerzeichen im pfad
daran kanns wohl nicht liegen...
danke trotzdem!

Autor: Dominic R. (dominic)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Scheinbar versucht dein Eclipse, den Prozess lokal zu starten, was 
natürlich fehlschlägt (der x86 Windows PC kann mit der ARM Binary nicht 
viel anfangen).

Auf www.yagarto.de (falls du das nicht onehin schon kennst) von Michael 
Fischer findest du ein How-To, das die Installation und Verwendung von 
Eclipse mit OpenOCD beschreibt.

Eventuell hat etwas bei der Installation der Zylin CDT Version 
fehlgeschlagen - die ist für Remote Debugging notwendig.

Gruss,

Dominic

Autor: Stephan S. (laglisse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
yagarto.de kenn ich und ich muss die seite erst mal loben! wirklich sehr 
gut!

bin nochmal die how to's auf yagarto durchgegangen und das tutorial vom 
james lynch, hab allerdings keine fehler in meinem setup gefunden.

ich werd mir schnell mein image draufbügeln und anschließend die 
toolchain neu installieren. mal schauen ob's hilft...

gruß,
stephan

Autor: Stephan S. (laglisse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab alles frisch drauf und genau nach tutorial.
-> leider gleiches ergebnis

??

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.