mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik UART Problem


Autor: Markus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
Ich habe ein Problem den Uart des at90s4433 zum Laufen zu bekommen. An
der Schaltung sollte es nicht liegen (MAX232), die hab ich getestet
(gemessen ob sich der Pegel verändert, wenn man z.b. den Eingang wo
eigentlich der uC dranhängt auf high setzt). Ich habe dann nun
schließlich den Code von http://www.mikrocontroller.net/articles/c/
genommen (UART Übung 3, nur eben einen MAX232 für die Schaltung.) Aber
es tut sich überhaupt nichts - soll heißen es wird nichts empfangen bzw
gesendet. Ganz genau nachmeßen kann ich das leider nicht, da mein
Multimeter wohl zu langsam dazu wäre. Ein Oszi hab ich nicht. Nun frage
ich mich woran das liegen könnte. Auf dem PC mit dem der AVR
kommunizieren sollte ist Linux drauf, vielleicht muss man ja dort
irgendwas besonderes einstellen?

Die einzige Sache die ich im Code aus dem Tutorial geändert habe:

Ich habe UCR in UCSRB (so wies auch im Datenblatt steht) geändert, da
es UCR anscheind nichtmehr in der avr-libc gibt.

So.. hat jemand ne Idee worans liegen könnte?

Autor: Markus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achso .. ganz vergessen, ich versuche das ganze in C.

Autor: Markus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, hat sich erledigt ;)
Danke für eure zahlreichen Antworten ;) g

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.