mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Webserver nach HolgerBuss


Autor: MÖMÖ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

diese Woche habe ich den Webserver nach  Holger Buss : "ATMEGA32 
Lochrasterplatine mit ISA_Slot" nachgebaut.
am Terminal sind alle Infos ok
dh: Karte wurde erkannt und initalisiert (34)
MY IP 192 168 1 66 <-ATMEGA32
IP 192 168 1 50 <- mein XP Rechner
PonyProg Fuse:
Haken lt. Anleitung

die Karte wurde vorher per DOS auf
Base 300
Interrupt 9
Medium auf Automatic
PNP aus
eingestellt.

mein Problem:
-am Hub leuchtet die LED nicht
-Ping geht nicht (100% Verlust)

-an meinem Rechner WIN XP -TCPIP korrekt eingestellt
-Firewall aus

Netzwerkkarte SN2000P (BNC / RJ45)
NE2000 kompatible

kurz :hat jemand einen Tipp, woran es liegen könnte ?

Danke für nen Tipp
Stephan

Lob an H.Buss / U.Radig
Dank an Elektriker wg Tipp Webseite

Autor: Thomas Finke (thomas-hn) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Karte mit ISA-Slot hört sich für mich stark nach 10 MBit an....kann Dein 
Hub 10 MBit oder nur 100 MBit? ;-)

Autor: MÖMÖ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,
Hab nachgeschaut:

100 Mbps Fast Ethernet Hub

das Ding ist jetzt ca. 4 Jahre alt und ich bin mir nicht sicher ob ich
die ISA Karten schon dran hatte, da ich auch PCI Karten haben.

ich hatte schon mal ein kleines Netzwerk mit Dos Client / Win 98 und das 
hatte
funktioniert auch mit 2 Karten in einem Rechner wg BNC.
ich dachte der Hub erkennt selber ob 10 oder 100

danke
Stephan




Autor: MÖMÖ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
UPS was soll den das?
hab gerade eine Diskette gefunden mit der gleichen Bezeichnung wie mein 
HUB
"FIBER LINE NETWORK ADAPTER"
kann mich aber nicht erinnern ob ich die jemals gebraucht habe.

Autor: MÖMÖ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
erledigt, war eine PCI _Disk

aber nochmal,

100 MBit Karte an 10 Mbit Hub geht und
10 Mbit Karte an 100 Mbit Hub geht nicht ?

stimmt das ?

Danke

Autor: Thomas Finke (thomas-hn) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Normalerweise geht nur:
10 MBit Karte an 10 MBit Hub
100 MBit Karte an 100 MBit Hub
10 MBit Karte an 10/100 MBit Hub
100 MBit Karte an 10/100 MBit Hub
10/100 MBit Karte an 10 MBit Hub
10/100 MBit Karte an 100 MBit Hub
10/100 MBit Karte an 10/100 MBit Hub

puh Hab nun glaub alle Kombinationen zusammen ;-)


> 100 MBit Karte an 10 Mbit Hub geht und
Dann war es wohl ne 10/100 MBit Karte die automatisch auf 10 MBit 
runtergeschaltet hat.

> 10 Mbit Karte an 100 Mbit Hub geht nicht ?
Dann war der Hub wohl "intelligent" und hat runtergeschaltet.

Gruß,

Thomas

Autor: MÖMÖ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So das wars,

habe mich gerade auch "schlau" gemacht

meine Kombination geht nicht : 100 Hub an 10er Karte
muß einem dochmal gesagt werden

- ohne deinen Tipp ( Thomas Finke) wäre ich niemals auf die Idee 
gekommen das dies der Fehler sein könnte.

D A N K E

Autor: MÖMÖ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

alles funktioniert einwandfrei

hab nochmal einen alten Dos_Client mit TCPIP hergerichtet
diesmal mit BNC.

Meine Fehler :

gestern
1) ATMEGA32 mit Batterien / Accus betrieben
        keine Reaktion (Spannungseinbruch)
Abhilfe: PC Netzteil 5V

heute :
2) 100 Mbit HUB an 10 Mbit Netzwerkkarte
Abhilfe : ohne Hub über BNC (Koaxkabel)
werd mir Morgen einen neuen/alten HUB der 10/100 Mbits kann  besorgen

Nacht



Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.