mikrocontroller.net

Forum: Compiler & IDEs avrdude schreibt falschen Wert für lockbits


Autor: Thomas Siegmund (microbi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe mir ein Skript geschrieben welches einen ATmegaxx programmiert. 
Zuerst die Fusebits, dann EEPROM, FLASH und zum Schluß die Lockbits.
KLappt auch alles bis auf die Lockbits.
Avrdude beschwert sich dann beim Verify zurecht, dass dort ein anderer 
Wert geschrieben worden ist. Der Wert welcher zurückgelesen wird ist 
immer der Gleiche, nämlich 0xE0 und nicht der den ich eigentlich 
schreiben will z.B. 0xFC.

Hat jemand eine Idee dazu?


Grüße Thomas

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.