mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 4 Servos mit Atmega8


Autor: Sebastian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
HI,

Ich hab für nen Atmega8 ein programm geschrieben, mit dem ich 4 Servos 
ansteuere, bisher noch ohne Schnittstelle oder Bussystem.
Ich hab jetzt allerdings das problem, dass der Port C0, oder genauer 
derjenige Pin, der in der case 1 abfrage angesprochen wird, kein signal 
ausgibt. wenn ich jetzt allerdings den timer 2 auf OCR2 = TCNT2 + 
1(Zeile 30)  bzw. weniger  63 einstelle, kommt das signal wie erwartet.
ausserdem kann ich den timer 2 nicht genau einstellen. egal welchen 
Compare Match ich setze, der interrupt kommt immer beim overflow.

ich würde mich sehr freuen, wenn mir jemand helfen könnte, da ich mit 
dem programmieren von Mikrocontrollern neuland betreten habe.

Grüße, sebastian

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus der Codesammlung hierher verschoben

@Sebastian:
Die Codesammlung ist für funktionierenden Code gedacht,
den ein Autor anderen Programmierern zur Verwendung zur
Verfügung stellt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.