mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit ENDBUSRES bei ARM7S


Autor: Benjamin (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich versuche schon seit einiger Zeit mein Board von Olimex via USB an 
einen Rechner anzubinden.
Ich bin schon soweit das sich der Controller am PC anmeldet wenn er 
eingesteckt wird(gesehen durch USB-Sniffer).
Doch dann beim Test ob er wirklich richtig Configuriert wist bleibt er 
in der Schleife hängen.
Ich füge mal den Code an, es handelt sich dabei im die Funktion 
AT91F_UDP_IsConfigured in hid_enumerate.c
Weiss jemand woran das leigen könnte?

Ich weiss echt nicht mehr wo ich noch suchen soll und warum er dort 
hängen bleibt.

Danke!
MfG Benjamin

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.