mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik firmware weg


Autor: fischly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe grad ein STK 500 dass vermutlich keine Firmware mehr hat. (nur noch 
Power button leuchtet) wer weis rat wie mann auf des ding wieder ne 
Firmware draufbekommt??

THX

Fisch

Autor: Franz-Rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Updaten mit dem Studio geht das noch?

Autor: Franz-Rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einen Weg dürfte es geben. Dafür braucht man aber einen 2ten Programmer.
Was für einen ist egal.

Autor: fischly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke ! also unter tools update geht nix mehr. Wie gehts den mit dem 2. 
Programmer ?

Autor: Franz-Rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also....

Auf dem STK500 sind neben dem AT90S1200 6 Löcher.
Das ist der Programmieranschluß für für den Proz. der die Firmware laden 
kann. Ein ganz normaler 6pin ISP. In diesen Proz. muß die Atmel Firmware 
für den Prog. 910 aufgespielt werden. Den nur mit diesem kann man das 
File STK500.ebn in den Hauptprozessor laden.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das STK500 hat einen Lötplatz für eine Stiftleiste 2x3. Über diese kann 
man einen anderen Programmer anschließen. Dazu sollte man aber wissen, 
was man tut. Ich kann es nicht, weil es noch nicht nötig war, mein 
STK500 funktioniert immer noch prächtig.

...

Autor: Franz-Rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nochwas

http://www.atmel.com/dyn/products/app_notes.asp?fa...

AVR910: In-System Programming herunter laden.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aha, wieder was gelernt...

Danke...

...

Autor: Franz-Rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan vom STK500 gibt es in der Studio Hilfe

Autor: Franz-Rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Je nach Herstellungsdatum kann auf dem STK500 auch ein 2313 oder 
Tiny2313 verbaut worden sein. Das 910er File ist etsprechend dann 
anzupassen.

Autor: Franz-Rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So jetzt ist Feierabend. Weitere Fragen beantworten erst morgen nach 
10Uhr wieder.

Schönen Abend noch.

Autor: fischly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke,

schein ja nicht der einzige zu sein....

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also der AT90S1200 kann sich nicht von alleine löschen.

Höchstens der AT90S8535 kann durch ein fehlgeschlagenes Update tot sein.

Dann einfach nochmal mit AVRStudio das Update einspielen.


Peter

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du es denn schon mit der Datei "Upgrade.exe" im Unterordner STK500 
probiert?

...

Autor: fischly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
beim Start vom STK leuchtet einzig und alleine die Rote Power lampe. Die 
ganze Schei.. ist passiert nachdem ich unter Tools AVRProg auf Erase 
geklickt habe heul heul heul....

Die Upgrade zeigt mir im Status : No Programmer found


Autor: fischly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab natürlich keinen AT90S1200  sondern ein Attiny 2313 auf dem STK

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
fischly wrote:
> ich hab natürlich keinen AT90S1200  sondern ein Attiny 2313 auf dem STK

Macht nichts, der ist ja nur fürs Update zuständig.

Und da Du kein Update gemacht hast und es vorher ging, müsse beide Chips 
noch in Ordnung sein.
Es sei denn, Du hast direkt auf VCC mal 12V gegeben.

Erase gilt ja nur fürs Target.

Prüfe nochmal, ob Deine Wandwarze genug Saft gibt, VCC stimmt, Du am 
richtigen UART-Stecker sitzt, ziehe das Target und alle Kabel erstmal 
raus.


Peter

Autor: fischly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
STK zieht 80mA bei 10V und nur die Power leuchte ist an, UART hab ich 
schon 20 mal überprüft. Mit und ohne Quarz auch die Targets hab ich 
schon ausgetauscht was kanns den noch sein wenn nicht der Programmer?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.