mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik device missing or unknown device -24


Autor: Jörg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe diese Fehlermeldung beim programmieren eines AVR Mega8 mit
Ponyprog und wie ich jetzt so im Internet gesehen haben sehr, sehr ...
viele andere auch.

Ich benutze den Adapter für die Parallele-Schnittstelle von
www.Embedit.de. Einen AVR 2313 kann ich damit auch beschreiben. Den
Mega8 nur 3 mal danach gingen nur noch lesende Befehle. Habe keine
Fusebits verändert bzw. geschrieben. Spannung ist konstant 5,00V.

Mit SP12 und Yaap kann ich auch nicht aúf den Mega8 schreiben.

Vielleicht könnten hier einmal alle Ideen, Lösungsvorschläge usw.
einfließen damit man dem Problem auf die Schliche kommen kann.

Gruß Jörg

Autor: Rainer D (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich hätte ein paar mögliche Fehlerquellen:

- ISP Kabel zu lang ich hab die Erfahrung gemacht das mehr als 20cm
Probleme machen. Progger zu Platine/Steckboard

- Sind die MISO MOSI Signale richtig angeschlossen? Hmm müßten sie
eigentlich schon sonst würde der Programmer den MC gar nicht
erkennen.....

- Hängt and den MISO MOSI SCK Ports irgendwas dran? Das könnte die
Ursache sein das Daten verfälscht werden und so die Fuse bits falsch
setzen - ist mir mal passiert.

- Ist die Spannungsquelle stabil?

- Falls die Schaltung auf einem Steckboard aufgebaut ist: Sind alle
Kabel in Ordnung? Ich hatte mal nen Wackelkontakt in einer
Programmierleitung....

Viel Erfolg noch beim Fehlerfinden.....

MfG
Rainer

Autor: Martin Jansen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab mich auch grad noch damit rumgeschlagen, nur dass es fehler nr.
21 war, es lag einfach an nem wackler beim isp, nur bis man darauf
kommt....
wünsch dir das du den fehler bald findest

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.