mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 1 Byte über UART1 ATmega128 mit BASCOM AVR


Autor: Frank Sauder (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,
ich versuche mit einem ATmega128 1 Byte zu senden.
Es kommen aber immer 2 oder mehr Byte (je nach Datenbyte) aus dem UART1
heraus. Die gesendeten Byte sind auch völlig anders! ~:(
Hat jemand damit Erfahrung?

Mein Test:

$regfile = "m128def.dat"
$crystal = 16000000
$baud1 = 9600
open "Com2:" for binary as #1
print #1 , &b10000001 ; 'so werden einige Byte gesendet! Warum?
close #1
End

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.