mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik mysmartusb uart


Autor: damir (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich verwende den den usb-programmer mysmartusb von myavr.de .
jetzt wollte ich den uart ausprobieren, aber am notebook kommen nur 0er 
an, am programmer ist der datenmodus eingestellt (2 grüne LEDs 
leuchten), das programm funktioniert scheinbar auch : ich sende vom 
notebook ein zeichen und empfange es dann wieder über HTERM, aber es 
werden halt immer nur 0er angezeigt, sowohl im ascii als auch in dezimal 
und binär - format.
bei einem anderen terminalprogramm wie AVR TERMINAL ist es das selbe 
problem.
woran kann das liegen?

Grüße  damir

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.