mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit AVR-Studio (Strukturen)


Autor: Udo Z. (Firma: keine) (udoz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

ich nutze zur Programmierung Eclipse mit Win-AVR, gcc-Plug-In usw. in 
den jeweils neuesten Versionen. Zum Debuggen nutze ich die neueste 
Version von AVR-Studio.
avr-gcc wird mit der Option -g (Debug info) aufgerufen.

Problem: es werden in AVR-Studio keine Strukturen aufgelöst. Wähle ich 
einzelne Elemente im Watch an, wird nie ein Wert ausgegeben. Stattdessen 
wird immer nur "Not in scope" angezeigt.
Das kann ich umgehen, indem einer 'einfachen' Variablen den Wert eines 
Strukturelements zuweise. Aber das ist dann doch ziemlich umständlich.

Wie überrede ich AVR-Studio dazu, mir die Werte von Strukturen 
vernünftig anzugezeigen?

Danke, UdoZ

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.