mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Debuggen von LPC2148 mit Eclipse startet nicht


Autor: Jansus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe folgendes Problem:
Spiele gerade mit Eclipse usw. (Komplettpaket von Olimex) und einem 
LPC2148. Habe Beispielcode (war bei dem Paket dabei) kompiliert. Das 
klappt soweit. Leider funktioniert der Debugger nicht. Habe ihn wie im 
Tutorial beschrieben gestartet, also erst OpenOCD dann den Debugger. 
Nach einer ganzen Weile heißt es dann "Stack is not available: No 
registers". Mit dieser Fehlermeldung kann ich leider garnichts 
anfangen... zumindest habe ich keine Ahnung was ich machen kann um das 
Ganze doch noch zum Laufen zu bewegen.
Vielleicht hat von Euch ja jemand das selbe Problem gehabt oder sonst 
eine Idee bzw Ahnung?
Bin für alle Tipps und Ratschläge dankbar!

Mfg
Jansus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.