mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Simulation AD-Wandler im AVR-Studio


Autor: marc (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

Kann es sein, daß die Simulation des ADUs im AVR-Studio (4.13 Build 557) 
nicht mehr richtig tickt. Ich simuliere einen Tiny13 mit einem 
freilaufenden ADU. Die Umsetzung passiert aber nur genau einmal nach der 
Initialisierung (immerhin).
 out ADCSRA, 1<<ADEN|1<<ADSC|1<<ADATE|1<<ADIF|1<<ADIE|4<<ADPS0

Mache ich was falsch? Früher ging das mal...

Danke!
Marc

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wozu simulieren ? Programm in den Chip brennen
und ausprobieren. Das ist der 100% sichere Weg.
Dann verschwendet man auch keine Zeit ;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.