Forum: Mikrocontroller und Digitale Elektronik Mega16: zu dusselig, um JTAG zu deaktivieren?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Wolfram Szentiks (Gast)


Lesenswert?

Hi,

mein LCD Problem habe ich zwar auf den PortC eingrenzen können, jedoch
kriege ich es nicht hin, diesen Port auf die "normale" I/O Funtion
einzuschalten.
Hat jemand einen Tip griffbereit?
Danke und Gruß

Wolfram

von Joerg Wunsch (Gast)


Lesenswert?

Hast Du denn die beiden Fuses ordentlich abgeschaltet?  Insbesondere
JTAGEN ist standardmäßig eingeschaltet.

von Dominic Thomé (Gast)


Lesenswert?

Hallo,
mußt die Fuses setzen, genaugenommen das GFuse-High-Byte.
Tabelle 105, Seite 260 Dokumentation.
Bit 6 auf 1.


Bitteschön
Dominic

von Wolfram Szentiks (Gast)


Lesenswert?

Hmmm,

bin wirklich zu dusselig, oder irgendetwas fehlt mir...(bin noch
Anfänger).
Danke für die genaue Tabelle, habe ich gefunden, aber irgendwie bekomme
ich es nicht hin.
Welches Register denn, das MCUCSR Register muß ja auch wohl beschrieben
werden, oder?
Ach ja, ich benutze zwar BASCOm, aber die Zeilen, um ein Bit zu setzen
, kann ich ja in ASM einfügen..
Wie gesagt, schön langsam und deutlich bitte, bin Anfänger,
Hardware-Mann und blond...:))

Gruß Wolfram

von Dominic Thomé (Gast)


Lesenswert?

Die Fuses werde nicht im Programm gesetzt, das machst Du mit Deinem
Flashtool, welches benutzt Du denn ?

Dominic

von Wolfram Szentiks (Gast)


Lesenswert?

Hi Dominic,

Aha, benutze gerade das STK 500.
Fuse habe ich eigentlich disabled, jetzt habe ich ein kleines
Testprogramm geschrieben, um die Leds von den Ports anzusteuern.
Alle funzen, nur die plöde LED3 nicht...
Programm ist ok, wenn ich umstecke geht alles.
Daher kommen auch meine Probleme mit dem Display, denn da liegt laut
Standard-Belegung mein CD - Signal drauf.
Grr, seit ich vom 8515 umgestiegen bin, habe ich noch keine neue Zeile
geschrieben.
Dabei brauche ich den Platz fast nur für die Bildchen, die ich auf dem
Display ausgeben will.
Oder könnte ich die in das EEProm schieben und von dort anzeigen
lassen?
ups, jetzt komme ich von Hölzchen auf Stöckchen...

Gruß Wolfram

von Dominic Thomé (Gast)


Lesenswert?

Soviel ich weiß kansnt Du im AVR-Tool für Windows (ich denke das benutzt
Du), die Fusebits setzten. Ich selbst benutze Linux und uisp zum
flashen, kann Dir daher nun wenig helfen, gebe deswegen die Frage wie
man die Fuses bie Dir setzt weiter..... Dürfte aber irgendein Menüpunkt
sein ;-)

Dominic

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.