mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Studio Assembler


Autor: Christoph Zengel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Bei meinem AVR Studio ist irgendwie der Debugger kaputt...

Wenn ich "Trace Into" mache, zeigt er wild durcheinader Codezeilen
an, er simuliert einen Programmablauf, der überhaupt keinen Sinn macht.
Das Teil ist total verwirrt.

Und das krasse ist: Die Programme laufen auf dem echten Prozessor, wenn
ich sie hochlade...

Hatte jemand schonmal dieses Problem? Was ist zu tun?

Gruß
Christoph

Autor: Florian Pfanner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du mit AVRGCC arbeitest: Schau dir mal die FAQ dazu an. Da gibts
eine Rubrik 'Why does the PC randomly jump around when single-stepping
through my program in avr-gdb?' Dort dürftest du fündig werden.

Gruß, Florian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.