mikrocontroller.net

Forum: Compiler & IDEs AVRDUDE dll problem..


Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Experten,

ich habe bisher im AVR Studio mit dem avrisp meine Atmegas geproggt....
(WindowsXP). Ich möchte nun alles unter dem programmers Notepad2 machen. 
Ich habe dazu WinAVR-20070525 standardmäßig installiert. Das Übersetzen 
funktioniert auch soweit...
Aber ich kämpfe noch mit AVRDUDE....ich habe das noch nie benutzt...

Erstes Problem: Rufe ich in der Kommandozeile
>avrdude ?
auf bekomme ich eine Fehlermeldung..
"Die Anwendung konnte nicht gestartet werden, weil libusb0.dll nicht 
gefunden wurde. Neuinstallation der Anwendung könnte das problem 
beheben"

Die dll ist aber in C:\WinAVR-20070525\utils\libusb\bin  vorhanden. Muß 
man da nach der Installation noch etwas händisch eintragen?

Ferner was stellt man im MAKEFILE für einen AVRISP ein?

AVRDUDE_PROGRAMMER = avrisp      oder etwa stk500
AVRDUDE_PORT = com1
AVRDUDE_WRITE_FLASH = -U flash:w:$(TARGET).hex $(FUSE_BITS)
AVRDUDE_FLAGS = -p $(MCU) -P $(AVRDUDE_PORT) -c $(AVRDUDE_PROGRAMMER)

richtig?

Vielen Dank
Achim

Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ok.Ich bin ein Schritt weiter, nachdem ich den Artikel mit AVRDUDE mit 
dem Path Problem gelesen habe. Ich benutze aber kein USB 
Programmer....sondern einen Original Atmel AvrISP (seriell).

aber jetzt kommt folgende Fehlermeldung...

C:\>avrdude -c avrisp -p m16 -P com1 ?
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

Ich habe mitAVR Studio (4.13 Service Pack 2) den AVR ISP auf den 
neuesten Stand upgedatet. Dort kann ich problemlos mein Atmega 
programmieren. Wird diese version des AVR ISP (serielle Schnittstelle!) 
nicht unterstützt?

Bin für jegliche Hinweise dankbar.

MfG
Achim

Autor: Frank Lorenzen (florenzen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wahrscheinlich hast du mit dem AVR-Studio die Firmware des stk500 auf 
version 2 hochgezogen.
Probier doch mal "-c stk500v2".

gruss
f

Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Frank

jeep...das wars DANKE....ALler Anfang ist schwer....

Mfg
Achim

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.