mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Nokia 6100 + AVR, welche Einstellungen


Autor: Stephan Plaschke (steph0815)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich hab noch ein altes Nokia6100 rum fliegen und wollt das schon lange 
mal an nem AVR hängen. Dazu habe ich mir ein Datenkabel bei EBay 
besorgt. Dieses habe ich installiert und die Nokia Software dazu 
ausprobiert. Da ist dann auch schon das erste Problem denn die Software 
findet das Handy nicht. Das gleiche wenn ich einen AT Befehl(z.B. 
"ATD...") per Terminal sende.
Ich denke nun das es an der Übertragungsgeschwindigkeit liegt denn ich 
habe mit einem Oszi gemessen ob der Datenstrom richtig ausgegeben wird 
und da war kein Fehler festzustellen. Ausprobiert habe ich mit 9600Baud 
und 115200Baud. Einstelungen im Handy habe ich nicht gefunden und auch 
nichts im Internet. Auch die Pinbelegung ist richtig (siehe pinouts.ru). 
Ist dort unter Nokia Pop Port zu finden.
Hoffe hier kann mir jemand einen Tip geben oder vielleicht findet sich 
ja auch jemand der das schon selber zum laufen bekommen hat.

Danke
Stephan

Autor: Wulf-rüdiger Göpfert (wgoepf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe ein ähnliches Problem.
Habe Verbindung mit Hyperterm wie auch mit Nokia-Software getestet, 
bekomme aber auch keine Verbindung (z.B. durch test mit at)
Ich vermute , das liegt am Kabel (ebay ?!), aber wie kann man das 
testen?
Bzw welche Parameter sind einzustellen.

Autor: Stephan Plaschke (steph0815)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So ein wenig weiter bin ich schon gekommen. Ich habe mal den Oxygen 
Nokia Phone Manager ausprobiert. Damit bekomme ich auch eine Verbindung 
zu stande. Das ganze habe ich mir dann aufn Oszi angeschaut. Die 
initialisierung ist sehr lang und entspricht einer 0x55. Daher denke ich 
das es sich hier um das FBUS Protokoll handelt das am Anfang ja eine 
Synchronisierung mit 0x55 hat.
Habe auch schon gegoogelt nach FBUS und mir einiges angeschaut nur bin 
ich so richtig daraus noch nicht schlau geworde. Daher meine Frage ob 
hier eventuell jemand ist der sich auch schon mal damit befasst hat und 
mir etwas Hilfestellung geben kann, wär echt Klasse!

Edit
Ach ja die Geschwindigkeit liegt bei 115200Baud

Mfg
Stephan Plaschke

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.