mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit meinem Timer


Autor: Yves Durant (student76)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute, ich soll ein US Sensor aufbauen.Es soll mit analog signal
gesteuert werden.Die Frequenz ist 40KHz.I benutze ein R-2R Netzwerk als
8 Bit DA Wandler.Damit sollte ich ein Sinus siganl erzeugen.Der
Microcontroller(ARM9-STR912FAW44X6) generiert schon etwas aber ich kann
kein 40Khz haben.Ich habe ein Timer, der als Counter konfigiuriert ist,
benutzt.Mit Pll als interne clock mit 96Khz.Die IO ssind mit mein GPIO
verbunden.Wieso kann nicht kein 25us erreichen?Gibt es ein Weg, um meine
Frequenz zu erhöhen.
Danke

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.