mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit STK200, Mega8


Autor: JÜrgen Grieshofer (Firma: 4CKnowLedge) (psicom) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich hab mir eine STK200 zusammengschraubt (mit 74HC244) die Schaltung 
ist im Netz eh zu häufen vertreten. Die STK200 aus dem Grund, weil sie 
billig ist und ich sonst auf Mega32 arbeite und diesen mit dem JTAGer 
auch flashe.

So weit so gut, STK200 angeschlossen mit Ponyprog ein wenig gespielt und 
siehe da es funkt nicht.

Ich hab als Anhang mal die Signale der SPI Schnittstelle aufgezeichnet! 
Das ganze sollte ein Lesevorgang sein.

Normalerweise müsste der Controller die 2te Instruktion (53h) wieder 
zurückschicken od? Das tut er weder so, noch wenn ich MISO nicht 
angeschlossen habe (Meine Vermutung war Kurzschluss am STK)

Vllt kann mir ja jemand helfen xP


lg jÜrgen

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Setup Calibration duchgeführt und was sagt Probe?

Autor: JÜrgen Grieshofer (Firma: 4CKnowLedge) (psicom) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist alles OK...

Es funktioniert mit dem alten AVRStudio genauso wenig...


Aber ich werde jetzt mal in ein USBProgv3 investiern...

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit dem AVR-Studio funktionieren die ohnehin nicht.
Ein USB-Prog ist sicher eine gute Investition.

Autor: peter-neu-ulm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In dem Bild fehlt mir die Antwort des Objekts auf der MISO-Leitung. Hat 
das Objekt einen eigenen Takt ? liegt der ISP-Takt im Bereich, den der 
Takt des Programmierobjekts verträgt ?

Autor: JÜrgen Grieshofer (Firma: 4CKnowLedge) (psicom) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
peter-neu-ulm wrote:
> In dem Bild fehlt mir die Antwort des Objekts auf der MISO-Leitung. Hat
> das Objekt einen eigenen Takt ? liegt der ISP-Takt im Bereich, den der
> Takt des Programmierobjekts verträgt ?

Der Takt ist der interne Takt des Mega8 - 1Mhz (fusen lässt er sich ja 
noch nicht xD)

Der SPI Takt kommt vom PC (Mega8 ist Slave) und ist rund 50kHz wenn ich 
richtig liege xP

bin gerade noch ma beim durchforsten vom Datenblatt... vllt hab ich was 
überlesen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.