mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit Clampingdioden


Autor: Torsten S. (tse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich habe da ein kleines Problem.

Zwei AVRs teilen sich einen W1-Bus mit DS18x Sensoren. Mit einer 
zusätzlichen Statusleitung damit sich beide nicht in die Quere kommen. 
Funktioniert ausgezeichnet.

Beide AVRs sind in getrennten Geräten untergebracht und sollten auch 
unabhängig funktionieren. Tun sie leider nicht. Denn sobald einer 
stromlos wird schließt dieser durch die Clampingdioden den W1-Bus kurz.

Nun wollte ich nicht unbedingt ein Relais benutzen welches im 
spannungslosen Zustand den AVR vom Bus trennt. Kennt jemand eine 
elegantere Lösung, etwa mit einem Fet o.ä.?

Torsten

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.