Forum: Mikrocontroller und Digitale Elektronik MSP430 ADC-werte nicht stabil


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Wolfgang (Gast)


Lesenswert?

Hallo,
ich habe folgendes Problem bei Verwendung des 430F133:
bei Verwendung des ADC12 kommt es zu rel. starken Streuungen des
Meßwertes (bis zu +- ca. 10 Einheiten)
DVcc+AVcc sind jeweils mit 15µF+100nF abgeblockt.interne Ref-spannung
wird verwendet. die zu messende Spannung wird direkt an AVss und z. B.
P6.4 zugeführt.
muß man an der Sample&Hold-zeit noch etwas einstellen?
hat jemand schon Erfahrungen zur evtl. Lösung des Problems?
Gruß Wolfgang

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.