mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Evertool JTAG Problem


Autor: Thomas V. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hab mir das Evertool nachgebaut. Der ISP-Teil funktioniert auch
einwandfrei. Nur mit dem JTAG-Teil komm ich nicht klar. Wenn ich im
AVR-Studio JTAG wähle, dann findet er den JTAG-Adapter und den
verbundenen Controller mit ID. Alle weiteren Aktionen - z.b. Auslesen
des Flashs oder der Lockbits bringen jedoch nix - ausser meistens nen
Absturz des Studios. Wenn ich ein Programm debuggen will kommt folgende
Meldung:

Could not read lock bits of target device. Unable to continue connect
sequence.

Mache ich was falsch oder ist der Adapter nicht ok?

Vielen Dank für Eure Hilfe.

Thomas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.