mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Hilfe zu Parsic


Autor: Manuel Fellner (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich verwende den PIC Programmer P8048 (mit Experimentierboard)  von
Velleman mit PIC16F627.
Jetzt wollte ich Parsic ausprobieren.
Ich habe den Microcontroller eingestellt und ein einfaches Programm
erstellt. Dann mit MPASM umgewandelt und dann auf den PIC gespielt.
Auf dem Experimentierboard gibt es 4 Taster (mit RA.0-RA.3) und 6 LED’s
(RB.0-RB.5).
Wenn ich dann das Programm testen will, leuchten alle LED’s, die im
Programm nicht belegt sind. Wenn ich einen Timer auf einen Ausgang
hänge, blinkt oder leuchtet die LED aber nicht.
Was kann der Fehler sein?
Ich habe 2 Programme ins Netz gestellt:
http://www.memers.aon.at/m_fellner/Parsic_3.4.3.zip
Für eine Antwort bin ich dankbar: manuel.fellner@aon.at

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.