mikrocontroller.net

Forum: Platinen Kicad - 3D Bauteile werden nicht angezeigt


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: 3Dler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Ich würde gerne in Kicad die 3D Ansicht einer Platine bewundern. Die 
Platine ist mit Leiterbahnen und Bestückungsdruck schön sichtbar, aber 
die Bauteile nicht. Im PCBnew ist über "Rechtsklick -> Footprint -> 
Parameter Editieren -> 3D Einstellungen" ein 3D Modell zugewiesen 
(SMD-Widerstand, falls es was zur Sache tut). In der 3D Ansicht ist ein 
Haken bei "3D Footprints einblenden".

Nicht alle der Bauteile haben ein 3D Modell zugewiesen, da ich selbst 
einige Bauteile gebaut habe und dafür dann natürlich kein 3D Modell 
existiert. Ist das ein Problem? Was mache ich falsch?
Grüße

Autor: theriak (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Welche KiCad-Version, welches Bauteil/wrl?
Hatte bisher noch keine derartigen Probleme.

> Nicht alle der Bauteile haben ein 3D Modell zugewiesen, da ich selbst
> einige Bauteile gebaut habe und dafür dann natürlich kein 3D Modell
> existiert. Ist das ein Problem?
Normalerweise nicht. Du kannst auch in den Reitern "Layer" und "Render" 
Alles abwählen, ohne dass dies die 3d-Ansicht beeinflusst.

Autor: Max .. (mv1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi 3Dler,

Ich hatte vor ein paar Tagen ein ähnliches Problem. Alles sah gut aus, 
nur waren keine 3D Footprints zu sehen. (kicad bzr revision 5115)

Abhilfe brachte letztlich das Setzen der Umgebungsvariable 'KISYS3DMOD' 
vor dem Start von kicad.

  export KISYS3DMOD=/usr/local/share/kicad/modules/packages3d
  kicad

Vielleicht hilft das auch in Deinem Fall.

: Bearbeitet durch User
Autor: 3Dler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Max .. schrieb:
> Abhilfe brachte letztlich das Setzen der Umgebungsvariable 'KISYS3DMOD'
> vor dem Start von kicad.
>
>   export KISYS3DMOD=/usr/local/share/kicad/modules/packages3d
>   kicad

Danke! Das hat super funktioniert!

Für Leute, die in der Zukunft hier rüber stolpern, sei zusätzlich ein 
Artikel über Umgebungsvariablen gennant, in dem erklärt wird, wie man 
die dauerhaft setzt:
http://wiki.ubuntuusers.de/Umgebungsvariable

Grüße

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.