Forum: Offtopic Excel/OpenOfficeCalc Problem - ArtNr eingeben, Feld mit Bezeichnung automatisch füllen? Wie?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von D. M. (da_miez)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe grad ein kleines Excelproblem bzw. OpenOffice Calc was recht 
ähnlich ist, vielleicht hat ja jemand ne Idee :)

Habe rechts in der Tabelle eine Liste mit Artikelnummer und Bezeichnung.
Auf der linken Seite soll bei der Eingabe der Artikelnummer im Feld 
daneben dann automatisch die Bezeichnung erscheinen, die in der rechten 
Liste unter dieser Nummer vermerkt ist.



Hoffe das war verständlich erklärt. Das Bild und die Datei ist nur als 
Beispiel, brauche diese Möglichkeit in einer etwas umfangreicheren 
Tabelle.

Vielen Dank schonmal für jede Hilfe!

von D. M. (da_miez)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ok, hab ne Lösung gefunden. Mit dem Befehl "SVERWEIS" funktioniert das.

Das nächste Problem ist allerdings, dass die Liste erst nach und nach 
erweitert wird und die Funktion quasi in jedem Feld nach unten 
erscheinen soll.

Fehlt der Eintrag bei Artikelnummer zeigt es im SVERWEIS Feld natürlich 
eine "Fehlermeldung".

Kann man das irgendwie ausblenden solange im Feld Artikelnummer noch 
nichts steht?

: Bearbeitet durch User
von Johannes S. (demofreak)


Bewertung
1 lesenswert
nicht lesenswert
Noch ein WENN außen herum, welches prüft, ob in der Zelle in Spalte A 
etwas drin steht.

/Hannes

von D. M. (da_miez)


Bewertung
1 lesenswert
nicht lesenswert
Johannes S. schrieb:
> Noch ein WENN außen herum, welches prüft, ob in der Zelle in Spalte A
> etwas drin steht.

Perfekt, funktioniert :)

Dankeschön!



Das war die Lösung:

 =WENN(B2="";"";SVERWEIS(B2;L2:M98;2))

statt

=SVERWEIS(B2;L2:M98;2)

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.