mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Interessante Phänomen beim AVR-IAR


Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,
ich habe hier ein interessantes Phänomen beim AVR-Compiler von IAR
gefunden:
Wenn ich das "Debug"-Compilat mit Hilfe des JTAG ICE mkII im System
laufen lasse, funktioniert das Programm einwandfrei.
Wenn ich aber das "Release"-Compilat des gleichen Programms in den
Chip brenne, funktioniert es bis auf die Textausgabe über die USART
genauso wie das "Debug"-Compilat.

Hat jemand dafür eine Erklärung?

Gruß Rahul

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.