Forum: PC Hard- und Software phpinfo() gibt falsche Werte zurück


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von nicht "Gast" (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich habe einen Apache 2.4er Webserver in Betrieb mit PHP 7.1.8. Und habe 
folgendes Problem: In der php.ini habe ich den opcache aktiviert mit

opcache.enable=1
opcache.enable_cli=1

und wenn ich das im Terminal teste, sieht es auch ganz gut aus:

# php -i | grep opcache.enable
opcache.enable => On => On
opcache.enable_cli => On => On
opcache.enable_file_override => Off => Off


Aber, wenn ich auf einer simplen Website das testen will, mit

<?php
phpinfo();
?>

dann steht dort:

opcache.enable_cli: off


und ich kann mir nicht erklären wieso. Wie mann man herausfinden, 
weshalb die Ausgabe von phpinfo() falsch ist?

von Peter II (Gast)


Bewertung
0 lesenswert
nicht lesenswert
nicht "Gast" schrieb:
> und ich kann mir nicht erklären wieso. Wie mann man herausfinden,
> weshalb die Ausgabe von phpinfo() falsch ist?

kann sein das du fast-cgi verwendst? Dann musst du alle PHP Prozesse neu 
starten. Oder das es für den Apache eine andere php.ini gibt?

von H. E. (hobby_elektroniker)


Bewertung
1 lesenswert
nicht lesenswert
nicht "Gast" schrieb:
> Hi,
> ich habe einen Apache 2.4er Webserver in Betrieb mit PHP 7.1.8. Und habe
> folgendes Problem: In der php.ini habe ich den opcache aktiviert mit
>
> opcache.enable=1
> opcache.enable_cli=1
>
> und wenn ich das im Terminal teste, sieht es auch ganz gut aus:
>
> # php -i | grep opcache.enable
> opcache.enable => On => On
> opcache.enable_cli => On => On
> opcache.enable_file_override => Off => Off
>
>
> Aber, wenn ich auf einer simplen Website das testen will, mit
>
> <?php
> phpinfo();
> ?>
>
> dann steht dort:
>
> opcache.enable_cli: off
>
>
> und ich kann mir nicht erklären wieso. Wie mann man herausfinden,
> weshalb die Ausgabe von phpinfo() falsch ist?

Welche php.ini hast du angepasst? Die für CLI oder für Apache?

Schau mal bitte nach.
1
ls -lisahrt --color /etc/php/7.0/

Entweder dort entsprechend ggf. beides anpassen oder gleich in 
"mods-available", so dass es überall "gleich" aktiviert ist.
Apache, fpm-php, fast-cgi neu starten.

: Bearbeitet durch User
von T.roll (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Was steht den jeweils bei "Loaded Configuration File"?

von Ordner (Gast)


Bewertung
0 lesenswert
nicht lesenswert
T.roll schrieb:
> Was steht den jeweils bei "Loaded Configuration File"?

Hey, das wars! Da stand /etc/php-ztd.d/php.ini
Meine /etc/php.ini wird komischerweise ignoriert :-/

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.