Forum: Mikrocontroller und Digitale Elektronik SIM900A, nur ECHO


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Hugo P. (portisch)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat jemand dieses SIM900A Modul im Einsatz?

Ich habe Probleme mit der RS232.
So wie auf den Foto bekomme ich eine Verbindung per TTL 5V, 1200 Baud.
Jedoch bekomme ich nur ein Echo zurück:
TX: AT<\r><\n>
RX: AT<\r><\n>


Dann habe ich mal die 3 Jumper entfernt und eine echte RS232 Verbindung 
hergestellt. Da ist die Baudrate 19200. Jedoch auch hier nur ein Echo.

Ich benutze HTerm zum Testen.

Bin ratlos...

von BlaBla (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Probiere doch mal einen anderes Kommando. Zum Beispiel AT+GMR

von BlaBla (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Und das hier ist auch zu empfehlen:
https://www.mikrocontroller.net/articles/Sim900

von Hugo P. (portisch)


Bewertung
0 lesenswert
nicht lesenswert
Jedes Command wird nur per Echo quittiert.
Habe auch so versucht :
TX: AT<\r><\n><\r><\n>

Auch nur das Echo.

Habe aber keine SIM Karte im Modul, dass sollte aber für die RS232 egal 
sein, oder?

von BlaBla (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hier ist noch ein wichtiger Link:
http://dostmuhammad.com/blog/sim900-firmware-update-tutorials-appnotes/

Mein SIM900A war mit der Firmware für den asiatischen Markt ausgeliefert 
worden. Für Deutschland musste eine andere Firmware eingespielt werden. 
Vielleicht liegt es daran. Ich meine aber, dass zu mindestens ein paar 
Befehle mit Infos geantwortet haben.

von BlaBla (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hugo P. schrieb:
> AT<\r><\n><\r><\n>

Aber das ist doch kein richtiger Befehl. Und versuch mal AT+GMR<CR>. 
Ohne<LF>.

von BlaBla (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe diese Firmware eingespielt:
1137B09SIM900B32_ST.rar

von Hugo P. (portisch)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
TX: AT+GMR\r\n
RX:  41 54 2B 47 4D 52 0D 0A (AT+GMR\r\n)

Habe jetzt auch eine Schematic zu dem Modul gefunden.
Aktuell habe ich die 3 Jumper entfernt und hänge auf P2 Pin 1 & 3 mit 
der RS232 vom PC. Hier habe ich Baud 19200. Nur Echo...

von BlaBla (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vorsichtig! Die RS232 hat bis zu +/-15 Volt.

von BlaBla (Gast)


Bewertung
0 lesenswert
nicht lesenswert
An TX900 und RX900 dürfen nur 3.3V eventuell auch 5V liegen!

von Hugo P. (portisch)


Bewertung
0 lesenswert
nicht lesenswert
Habe jetzt den MAX3232 nachgelötet und nun bekomme ich ein OK vom 
SIM900A Modul! Scheint nun also zu funktionieren!!

von BlaBla (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Den Gedanken einer Zinnbrücke hatte ich auch gehabt. Dann ist ja alles 
gut. Jetzt musst Du nur noch prüfen, ob das Modell schon auf die 
Frequenzen für Deutschland umgestellt ist. Wie gesagt: die richtige 
Firmware ist wichtig. Und die für das SIM900B sollte gehen.

von Hugo P. (portisch)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt noch keine neue Firmware aufgespielt.
Wenn ich das Modul befrage kommt das raus:
AT+CGMI
SIMCOM_Ltd

AT+CGMM
SIMCOM_SIM800A

AT+CGMR
Revision:1418B04SIM800A24

AT+CGSN
8639870325xxxxx

AT+CIMI
2320330150xxxxx

Was den jetzt? SIM900A oder SIM800A??

Habe mir extra das SIM900A wegen dem Sleep Mode bestellt. Da soll der 
Stromverbrauch auf <2mA runtergehen. Bei meinem bleibt er bei ~36mA.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.