Forum: Platinen Altium Snap Grid per Shortcut deaktivieren


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Tsag (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe eine ganz komische Frage. Wenn ich im Schaltplan bin und 
Bauteile verschiebe, schaffe ich es manchmal den Snap Grid zu 
deaktivieren. Ich drehe z.B. ein Bauteil und betätige die falschen 
Tasten und kann das Bauteil plötzlich frei bewegen. Wenn ich dann ein 
anderes Bauteil auswähle ist der Snap Grid wieder aktiviert.

Keiner meiner Kollegen kennt solch einen Shortcut und im Internet habe 
ich auch nichts dazu gefunden.

Da mir das jetzt schon öfter passiert ist, würde ich gerne wissen, was 
ich für Tasten betätige. Hat irgendjemand eine Ahnung, mit welchem 
Shortcut man im Schaltplan den Snap Grid kurzzeitig deaktivieren kann?

von Wühlhase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Strg gedrück halten. (Oder Shift, ich verwechsle die beiden Tasten da 
gelegentlich.)

von Taz G. (taz1971)


Bewertung
0 lesenswert
nicht lesenswert
Mich würde die AD Version interessieren.
Ich habs bei AD17 und Nexus2 versucht zu provozieren - ohne Erfolg.
Ich finde auch keinen Shortcut zum ein/ausschalten vom Snap. In den 
Board Options gibt es eine Checkbox ist aber keinem Hotkey zugewiesen. 
Unter Costomize finde ich auch keinen Befehl.
STRG,Shift,ALT,ALTGR und viele Kombinationen habe ich getestet, kein 
Effekt auf den Snap Grid.
Sind die Presets in den Preferences vielleicht falsch ?


PS: nur weil ich keinen Shortcut finde heisst das nicht, dass es keinen 
gibt. Ist auf jeden Fall nicht in der Altium Dokumentation.
PPS: Nur um sicher zu gehen wir reden vom Schematic nicht PCB.

von Tsag (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Taz G. schrieb:
> Mich würde die AD Version interessieren.
> Ich habs bei AD17 und Nexus2 versucht zu provozieren - ohne Erfolg.

Ich habe auch den AD17. Provozieren konnte ich das leider auch nicht. 
Nur ohne Absicht schaffe ich das aber irgendwie.

Taz G. schrieb:
> Sind die Presets in den Preferences vielleicht falsch ?

Die Presets von Snap Grid stehen bei mir auf 10mil (Zur Auswahl sind 
noch 50mil und 100mil). In den Document Options stehen der Snap Grid auf 
10 DXP Units.

Taz G. schrieb:
> PPS: Nur um sicher zu gehen wir reden vom Schematic nicht PCB.

Schematic ist richtig.

Taz G. schrieb:
> PS: nur weil ich keinen Shortcut finde heisst das nicht, dass es keinen
> gibt. Ist auf jeden Fall nicht in der Altium Dokumentation.

Oder es ist ein Bug, der durch irgendwelche Einstellungen zustande 
kommt.

von Taz G. (taz1971)


Bewertung
0 lesenswert
nicht lesenswert
Tsag schrieb:
> Oder es ist ein Bug, der durch irgendwelche Einstellungen zustande
> kommt.

möglich.

Aber wenn man aus Versehen irgendwelche Tasten drückt können halt 
'komische' Dinge passieren. Wenn Du irgendwann mal heraus bekommst 
welche Tastenkombination es ist, kann man beurteilen ob Bug oder 
Feature.

von Frank S. (schroederde)


Bewertung
0 lesenswert
nicht lesenswert
War das nicht die Taste g?

von Wühlhase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
g ändert die Gridrasterung, deaktiviert es aber nicht.

von Frank S. (schroederde)


Bewertung
0 lesenswert
nicht lesenswert
War es nicht so? Standard Grid 10 - ertes mal g Grid 5 - zweites mal g 
Grid 1. Grid 1 entspricht gefühlt Grid aus.

: Bearbeitet durch User
von Wühlhase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Frank S. schrieb:
> Grid 1 entspricht gefühlt Grid aus.

Wenn du soweit rauszoomst daß ein A4-Schaltplan auf dem Monitor noch 
Briefmarkengröße erreicht, dann schon. Bei gebräuchlichen Ansichten kann 
ich das aber nicht bestätigen.

von Taz G. (taz1971)


Bewertung
0 lesenswert
nicht lesenswert
Frank S. schrieb:
> Grid 1 entspricht gefühlt Grid aus.

Grid 1 = 10mil = 0,254mm

Wenn man in Documents-Options den Haken bei Grids-Snap raus nimmt werden 
noch 3 Nachkommastellen angezeigt (intern sind es aber noch mehr). Also 
Grid 1 gefühlt aus aber programmtechnsch noch weit weg.

von Tsag (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Frank S. schrieb:
> Grid 1 entspricht gefühlt Grid aus.

Mh, ja fühlt sich schon ein bisschen an, als wenn Snap Grid 
ausgeschaltet ist. Ich will nicht ausschließen, dass es das war. Auch 
wenn es mich wundert, dass beim Auswählen des nächsten Bauteils, der 
Snap Grid wieder normal funktioniert hat.

Wenn es das ist, hätte ich natürlich lange nach dem Shortcut zum 
deaktivieren des Snap Grid suchen können.

von Purzel H. (hacky)


Bewertung
0 lesenswert
nicht lesenswert
Ja. Da war doch etwas mit Layoutgrid ausschalten .. allenfalls mit CTRL 
gedruckt halten. Dazu gibt es auch das Altium Forum.

von Taz G. (taz1971)


Bewertung
0 lesenswert
nicht lesenswert
Name H. schrieb:
> Ja. Da war doch etwas mit Layoutgrid ausschalten .. allenfalls mit CTRL
> gedruckt halten. Dazu gibt es auch das Altium Forum.

Nein

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.