Forum: PC Hard- und Software Win10: Link auf Netzwerkprogramm


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Angsthase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe für folgendes Problem leider unter Win10 keine Lösung gefunden:

- Datei "C:\Irgendwas\D\Projekte\Test.exe" angelegt
- Verzeichnis unter "C:\Irgendwas\D\" als Laufwerk D: eingebunden
 jetzt existiert die Datei D:\Projekte\Test.exe und kann auch ausgeführt 
werden

nun möchte ich eine Verknüpfung auf den Desktop ablegen 
"D:\Projekte\Test.exe"
leider findet Win10 diese Datei nicht unter diesem Link und wenn ich in 
Eigenschaften der Verknüpfung gehe, wird mir mitgeteilt das der Ordner 
unter Arbeitsverzeichnis ungültig ist, genaus das Ziel !!

Hat da jemand eine Idee

Danke

von Schlaumaier (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Klar, verlinke die Original-Datei.

Links auf Links ist ein bisschen viel Links ;)

von Angsthase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Schlaumaier schrieb:
> Klar, verlinke die Original-Datei.
>
> Links auf Links ist ein bisschen viel Links ;)

das geht aber das war nicht die Frage.

Mein Problem ist, ich habe diesen vorgegebenen Pfad 
"D:\Projekte\Test.exe" und kann dazu auch keine neuen HDD oder USB-Stick 
einbinden, einzig die Partition C: dazu verwenden

von Angsthase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
selbst wenn ich ein anderes Icon in der Verknüpfung wählen möchte, wird 
mir gesagt Win10 könne die Datei nicht finden

von Schlaumaier (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Wie hast du den Link den erstellt. ?? Mit den ""subst " Befehl unter 
CMD. ??

Weil ich habe (ok win 7) damit keine Probleme.

von Angsthase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Schlaumaier schrieb:
> Wie hast du den Link den erstellt. ?? Mit den ""subst " Befehl unter
> CMD. ??
>
> Weil ich habe (ok win 7) damit keine Probleme.

nein, das kann ich leider nicht, LW D: muss aus besonderen Gründen ein 
Netzwerklaufwerk sein und der "Subst" ist da nich anwendbar.

Ich habe das Verzeichnis freigegeben mit der Netzwerkfreigabe, dann das 
freigegebene Verzeichnis als Netzwerklaufwerk eingebunden

von Klaus P. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hast Du schon versucht, mit mklink einen symbolischen Link anzulegen?

Generell funktionieren Verknüpfungen auch mit Netzlaufwerken, aber nur 
im Explorer. Wenn Du den Pfad in einem eigenen Programm benutzt, 
solltest Du einen Link anlegen, der funktioniert auf der Ebene des 
Dateisystems. Geht aber WIMRE nicht mehr bei ReFS, nur nei NTFS.

von oszi40 (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ohne jetzt alles genau in Deiner Variante probiert zu haben,
würde ich erst mal net use /? das LW zuweisen
und später eine bat od. cmd starten wo die Datei Deiner Wünsche 
aufgerufen wird. Evtl. sind noch ein paar PW und Rechte zu beachten.

von Angsthase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> Ohne jetzt alles genau in Deiner Variante probiert zu haben,
> würde ich erst mal net use /? das LW zuweisen
> und später eine bat od. cmd starten wo die Datei Deiner Wünsche
> aufgerufen wird. Evtl. sind noch ein paar PW und Rechte zu beachten.

ja mit net use habe die Zuweisung gemacht und die Zugriffsrechte sind 
richtig gesetzt. Ich kann mit dem TotalCommander auch ganz normal auf 
das Laufwerk und die Dateien starten, auch benötigte INI Dateien werden 
gefunden, nur die Win10 Krücke ist einfach zu dumm das Laufwerk zu 
akzeptieren und unter dem Laufwerksbuchstaben es so zu akzeptieren, dass 
man auch Links anlegen kann.

Ich finde es schon bescheiden, das man seit Win10 bei einer Verknüpfung 
Aufrufparameter in "" einschließen muss

von Sven L. (sven_rvbg)


Bewertung
0 lesenswert
nicht lesenswert
Also ich kann bei mir EXEn ausführen, die auf einem Netzlaufwerk liegen, 
auf die ich eine Verknüpfung auf den Desktop angelegt habe.

(Desktop, rechte Maus, neue Verknüfung, Pfad zur EXE)

Eventuell UAC-Problem?

von Angsthase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sven L. schrieb:
> Also ich kann bei mir EXEn ausführen, die auf einem Netzlaufwerk liegen,
> auf die ich eine Verknüpfung auf den Desktop angelegt habe.
>
> (Desktop, rechte Maus, neue Verknüfung, Pfad zur EXE)
>
> Eventuell UAC-Problem?

hast du mal versucht auf dem Rechner ein freigegebenes Vezeichnis als LW 
zu mounten über net use?

von Sven L. (sven_rvbg)


Bewertung
0 lesenswert
nicht lesenswert
Angsthase schrieb:
> hast du mal versucht auf dem Rechner ein freigegebenes Vezeichnis als LW
> zu mounten über net use?

Jo, geht, kein Problem.

von Angsthase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Sven L. schrieb:
> Jo, geht, kein Problem.

habe es jetzt zuhause auf meinem Laptop getestet und geht, könnte dann 
doch an der UAC liegen weil es in der FIrma nicht geht

von Angsthase (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Habe das Problem gefunden

es gibt einen Registry Eintrag, der die Freigaben zwischen User und 
Admin verbindet, damit hat man die Möglichkeit auch im Anmeldescript, 
das mit erhöhten Rechten läuft, dem User Netzwerkfreigaben zuzuweisen
1
[HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
2
"EnableLinkedConnections"=dword:00000001

nach einem Neustart wird der Key aktiv und mit "net use" zugewiesene 
Laufwerke im Anmeldescript sind auch beim User im Explorer sichtbar

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.