mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit UART (Bluetooth)


Autor: Oz zy (ozzy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich probiere mittels UART Daten über ein Bluetooth-Modul an den PC zu 
senden. Den Code habe ich hier aus dem Forum UART. Nur funktioniert 
er irgendwie nicht. Das Problem ist, dass er nichts senden, da er 
anscheinend immer an diesen Zeilen hängen bleibt:
serout:
sbis UCSRA,UDRE                   ; Warten bis UDR für das nächste
                                  ; Byte bereit ist
rjmp serout

Irgendwie scheint UDR also nie für das nächste Bit bereit zu sein. Hat 
jemand von Euch da eine Idee, woran das liegen könnte?

Vielen Dank schon einmal im Voraus, Ozzy

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.