mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP bei AVR Butterfly


Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,
ich habe hier ein Butterfly der sich nicht programmieren lässt. 
Zumindest nicht über die ISP.
Irgendwer hat da Stiftleisten drauf gelötet und wenn ich an den Messe 
hab ich ein Verbindung zwischen Pin 4 (MOSI) und 6 (GMD). Das kann doch 
nicht richtig sein, oder?

Ich habe es mit einem AVRISP mkII und AVR Studio4 versucht aber da geht 
nix.
Wenn ich das Kabel falschrum drauf stecke dann leuchtet die LED sofort 
grün. Wenn ich es aber mit der roten Seite auf Pin 1 stecke dann ist die 
LED rot.

mfg
Florian

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Morgen,

Ist denn die Stiftleiste auch auf der richtigen Seite?

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm... gute Frage.
Sie ist von oben reingesteckt und angelötet.
Daran habe ich noch garnicht gedacht.

Ich habe noch mal die ISP von einem andern Bord (selbst gemacht) 
gemessen, da sind 4 und 6 nicht verbunden.

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
von Oben is schon richtig, aber 4 und 6 sollten nicht verbunden sein!

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also die Pins stehen nach oben, was ja auch Sinn macht vom Logischen 
aufbau her. Ist ja doof von unten. Aber wenn ich am AVRISP mkII den Pin 
eins suche ist das genauso von der belegung wie die ISP nur dann passt 
das ja nicht auf ein ander. Von unten würde der Stcker passen, so ligt 
aber die 1 auf 2.

Daufsicht ISP        Draufsicht Stecker AVRISP mkII
  2 4 6                 2 4 6
  1 3 5                 1 3 5

Das kann doch nicht passen, oder bin ich jetzt total blöd?

Autor: 1293 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der ISP Stecker kommt von oben, der JTAG von unten. Hab beide am Laufen.

Autor: 1293 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beide Kabel vom Dragon her.

Autor: Yves (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Florian

Habe gerade das gleiche Problem! Hast du eine Lösung gefunden?

MfG

Yves

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.