mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Vtarget LED leuchtet immer


Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich habe folgendes Problem:
Meine Vtarget LED leuchtet immer trotz offenen Jumper und das Board 
versorgt auch stetig den MC mit Spannung. Hat jemand eine Ahnung wie ich 
das behebne könnte?

Autor: Jim Knopf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Von was redest du? STK500?

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich vermute mal, dass Du von einem STK500 redest...

Und Du bist ganz sicher, dass keine externe Spannungsquelle dranhängt? 
Macht ja ansonsten eigentlich keinen Sinn, den Jumper abzuziehen. Wenn 
der Controller keinen Saft hat, geht nunmal nix...

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die LED auf dem STK 500

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Micha wrote:
> die LED auf dem STK 500
Um ganz sicher zu gehen: Bist Du sicher, dass der Saft vom Board 
kommt? Halte ich bei offenem Jumper nämlich für sehr unwahrscheinlich!

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe den Jumper abgenommen und die LED leuchtet immer noch.

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Macht schon Sinn, wenn man z.B. das STK nur als in-circuit-Programmer 
verwenden will und ein Aufsteckboard montiert hat ;)

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael G. wrote:
> Macht schon Sinn, wenn man z.B. das STK nur als in-circuit-Programmer
> verwenden will und ein Aufsteckboard montiert hat ;)
Dann muss das Target aber von außerhalb mit Saft versorgt werden. Und 
wenn die externe Versorgungsspannung (z.B. über den ISP-Stecker) mit der 
Target-Section des STK500 verbunden ist, dann leuchtet die LED 
ebenfalls, auch bei entferntem Jumper...

Da Micha sich aber beharrlich darüber ausschweigt, was er da tatsächlich 
angeschlossen hat, kann man nur raten...

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DEr Jtag Adapter steckt zwar drauf aber ein Board ist nicht 
angeschlossen.

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Micha wrote:
> DEr Jtag Adapter steckt zwar drauf aber ein Board ist nicht
> angeschlossen.
Und Du glaubst, "der JTAG-Adapter" hat keine Versorgungsspannung?

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zur Zeitl ist also nichst angeschlossen

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Letztendlich dürfte die LED nicht leuchten wenn der Jumper nicht steckt.

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Micha wrote:
> Letztendlich dürfte die LED nicht leuchten wenn der Jumper nicht steckt.
Doch! Die LED hat mit dem Jumper nichts zu tun! Die LED zeigt an, ob die 
Target Section des STK Spannung hat oder nicht. Und wenn von außen (also 
über einen anderen Adapter oder ein Zusatzboard) eine Spannung 
eingespeist wird, dann hat die Target Section Spannung und folglich 
leuchtet auch die LED. Ohne Spannung funktioniert in der Target Section 
gar nichts!

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab keine weitere externen Spannungsquellen angeschlossen.Ich hatte 
eine angeschlossen und hatte den Jumper stecken lassen. Mein Fehler. Es 
lagen aber nur 5 Volt an Kaputt gehen kann da ja eigentlich nichst.

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du den JTAG-Adapter dran hast, dann ist auch Spannung da (sollte 
zumindest)! Ohne Spannung am Target funktioniert auch kein JTAG...

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der jtag adapter ist nicht angeschlossen.

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann ist irgendwas gewaltig kaputt...

Autor: Anonymous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pull out the AREF jumper.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.