mikrocontroller.net

Forum: www.mikrocontroller.net Übersicht "Forum: Neue Beiträge" auf Startseite ändern


Autor: Markus Burrer (Firma: Embedit Mikrocontrollertechnik) (_mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich schaue immer wieder gerne hier rein. Was mich aber stört ist die 
Übersicht der letzten Beiträge auf der Startseite. Da landet man immer 
direkt bei dem jeweiligen Posting, was ich aber meistens gar nicht will.

Wenn ich zb mal ein paar Stunden nicht reingeschaut habe steht da 
vielleicht irgend ein "Re: irgendwas zu irgendwas" von einem Thread den 
ich noch nicht kenne. Ich muss also anklicken (man sieht ja auch nicht 
in welchem Forum der gepostet wurde), lande bei dem letzten Beitrag und 
muss erstmal bis nach oben scrollen.

Noch schlimmer ist es wenn ich bis zu einem gewissen Punkt gelesen hab. 
Dann muss ich entweder zum letzten Post springen und den letzten Post 
suchen den ich gelesen hab oder ich geh zuerst in das Forum und lande 
danke des #new Links an der richtigen Stellen.

Last but not least spülen besonders aktive Threads häufig alle anderen 
aus der Übersicht.

Ich würde daher vorschlagen die Übersicht so zu gestalten wie in den 
Foren selbst, also jeder Thread taucht nur einmal auf und statt dem Link 
auf den letzten Post gibts den Link auf #new.

Was meint ihr? Ich finde es so wie es jetzt ist ausgesprochen 
unpraktisch

Autor: Thomas B. (yahp) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich würde daher vorschlagen die Übersicht so zu gestalten wie in den
> Foren selbst, also jeder Thread taucht nur einmal auf und statt dem Link
> auf den letzten Post gibts den Link auf #new.

Dem würde ich auch zustimmen, bleibt die Frage, was mit #new bei nicht 
angemeldeten Benutzern passiert. Wenn man dann nicht auf den direkten 
Beitrag, sondern auf den Start des Threads kommt, wird das sicher als 
nicht so förderlich angesehen.

Autor: Markus Burrer (Firma: Embedit Mikrocontrollertechnik) (_mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So lange er das richtige Cookie Speichert passiert das gleiche wie wenn 
er angemeldet ist. Hab mich erst vor kurzem registriert und habe 
eigentlich außer der Mail Benachrichtigung und der Editierfunktion noch 
keinen Unterschied festgestellt

Naja, wenn man auf unterschiedlichen Rechnern arbeitet ist es natürlich 
dumm. Dann fängt man jedes mal von vorne an

Autor: Kai G. (runtimeterror)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich würde daher vorschlagen die Übersicht so zu gestalten wie in den
>Foren selbst, also jeder Thread taucht nur einmal auf und statt dem Link
>auf den letzten Post gibts den Link auf #new.

Wär ich auch stark dafür.

Von mir aus kann die Liste auch gerne doppelt so lang sein ;)

Gruß

Kai

Autor: Jones (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klingt gut. Ich wäre auch dafür. Das stört mich auch schon lange

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab das jetzt so wie vorgeschlagen geändert.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt müssen Vielleser aber immer nach unter Scrollen. Und bei sehr 
langen Threads hat man die oberen 95% der Postings schon gelesen und nur 
die letzten zwei oder drei interessieren gerade.

Da fand ich die bisherige Variante besser, das man zu dem Posting 
geleitet wird, wo der Zeitstempel zugehört. Dann konnte man die zwei, 
drei Postings hochscrollen.

Btw.: Wenn man auf seiner Tastatur auf die "Pos1"-Taste drückt, kommt 
man sofort an den Anfang der Homepage, also zum ersten Posting. Die 
Taste "Ende" springt zwar gleicherweise ans Ende der Homepage, aber hier 
befindet sich ja noch das riesige Feld "Antwort schreiben", und man muss 
schon wieder scrollen.


MfG,
Thomas

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> aber hier befindet sich ja noch das riesige Feld "Antwort
> schreiben", und man muss schon wieder scrollen.

... hängt von der vertikalen Bildschirmauflösung ab. Bei 1600 Pixeln 
muss man nicht unbedingt scrollen ... aber ansonsten hast Du recht.

Eventuell könnte man das "Antwort schreiben"-Feld mit etwas DHTML hinter 
einem Link/Button verbergen.

Autor: Forumsleser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So wie das jetzt ist, gefällt mir das überhaupt nicht.
Man sieht nicht mehr ob jemand einen neuen Thread startet.
Eventuell wär es sinnvoll in der Übersicht anzuzeigen wieviel Beiträge 
zu einem Thread bereits gehören.
Und wenn jemand auf die Zahl klickt, ihn ans Ende des Threads zu 
befördern.
Also so wie vorher.


MfG

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir ist auch gerade aufgefallen, dass man auf den ersten Blick nicht 
mehr erkennt, ob es neue Beiträge gibt oder nicht. Da immer das erste 
Posting eines Threads erscheint, und dieses schon gelesen wurde, ist der 
Link anders gefärbt als ungelesene Postings. Bisher konnte man aufgrund 
der Farbe sofort sehen, ob man das Posting schon gelesen hat oder nicht. 
Jetzt muss man immer auf die Uhrzeit schauen, was ich extrem nervig 
finde.

MfG,
Thomas

Autor: Forumsleser (Gast)
Datum:
Angehängte Dateien:
  • 00.TXT (198 Bytes, 241 Downloads)

Bewertung
0 lesenswert
nicht lesenswert
Also etwa so:

siehe 00.TXT


Your post seems to contain Spam: \'\'.

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Super, danke. Ich finde das jetzt bedeutend besser. Vielleicht kann man 
ja noch ein paar Detailverbesserungen vornehmen das man zwischen neuem 
Thread und altem Thread unterscheiden kann (Anzahl der Antworten  in 
Klammer dahinter oder so).

Aber jetzt sieht man wenigsten mal ein paar Threads und nicht nur 20 
Antworten aus ein und dem selben Thread den man eh nicht lesen will

Vielen Dank an Andreas

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Vorschlag: vielleicht könnte man die Startseite noch um den Zusatz 
"Letzter Beitrag" wie in den Foren ergänzen. Schwarz wenn man alles 
gelesen hat, rot wenn's etwas neues gibt. Die Funktion ist ja da, muss 
nur eingebaut werden. Dann wird's halt ein bissel breiter

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ergänzung: einfach die Uhrzeit verwenden die eh schon angezeigt wird. 
Ist das ein Deal?

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Jetzt müssen Vielleser aber immer nach unter Scrollen. Und bei sehr
>langen Threads hat man die oberen 95% der Postings schon gelesen und nur
>die letzten zwei oder drei interessieren gerade.

Jetzt hab ich erst kapiert was Thomas für ein Problem hat. Kann es sein 
das du keine Cookies zulässt? Solltest du mal machen, zumindest das eine 
entscheidende. Oder biste so paranoid?

Also wenn ich einen 200 Post langen Thread gelesen habe und es kommt was 
neues, dann springe ich bis runter zum ersten Thread den ich noch nicht 
gelesen hab und kann ab da weiterlesen. Ich muss nicht scrollen. Ich 
lande genau da wo ich das letzte mal aufgehört hab, also genau da wo ich 
hin will

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Cookies sind an. Trotzdem wird immer zum ersten Post gesprungen.

Da neue Posts sowieso immer unten angehängt werden, finde ich es nur 
sinnvoller, dass dort hingesprungen wird und dass die Leute, die den 
Anfang verpasst haben, einfach auf "Pos1" klicken. Und nicht andersrum.
So wie es jetzt ist, können die Threads auf mehrere Seiten verteilt 
werden. Das würde es übersichtlicher machen. Aber als das mal zur 
Sprache kam, wurde das gleich niedergeschmettert.

Um die Sache von meiner Seite mal auf den Punkt zu bringen:
Ich bin kein Mensch, der sich gegen Änderungen wehrt. Aber ich besuche 
diese Seite mitlerweile seit mehr als 7 Jahren tagtäglich. Aber so wie 
das jetzt mit dieser Umstellung ist, find ich das echt zum Kozten. 
Jedesmal nach unten Scrollen oder auf "Ende" und dann nach oben.


MfG,
Thomas

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also zunächst mal: wenn du jetzt immer am Anfang landest stimmt bei 
deinem Browser etwas nicht.

Und als nächstes: ich will nicht am Ende landen sondern bei dem ersten 
Thread den ich noch nicht gelesen habe. Und genau das passiert bei mir 
auch

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann stimmt aber bei den Browsern auf 3 Rechnern was nicht. IE kann ich 
nicht probieren, weil der deinstalliert ist.

Vielleicht ist es ja möglich, das man diese Anzeigeart von noch heute 
morgen und jetzt als einstellbare Option für angemeldete User machen.

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Dann stimmt aber bei den Browsern auf 3 Rechnern was nicht.

Dann hast du entweder bei allen drei Browsern etwas verstellt oder du 
hast den falschen Browser.

Ich bin jetzt zb genau zu deinem Beitrag gesprungen, nicht an den 
Anfang. Dafür gibt es ja das #new in der URL

>Vielleicht ist es ja möglich, das man diese Anzeigeart von noch heute
>morgen und jetzt als einstellbare Option für angemeldete User machen.

Die alte Anzeige ist in meinen Augen Blödsinn. Stell den Browser richtig 
ein, dann wirst du sehen was ich meine

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab alle Einstellungen durch. Keine Änderung. Und die 3 Rechner wurden 
von 2 unterschiedlichen Leuten konfiguriert. Und es ist Firefox, neueste 
Version. Und in meinen Augen ist die aktuelle Einstellung Blödsinn.

Autor: M. V. (-_-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Hab alle Einstellungen durch.

JavaScript aktiviert? Falls nein, mach das mal...

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es kann eigentlich nur an den Cookies liegen. Ich habe zwei Cookies. Das 
eine heißt return_to und das zweite _session_id.

Ich weiß nicht ob man beide braucht. Ich hab sie jedenfalls erlaubt und 
speichere sie dauerhaft. Ich verwende auch Firefox, darf aber eigentlich 
mit dem Browser nichts zu tun haben. Hab gerade spaßeshalber mal 
Epiphany ausprobiert. geht auch wunderbar

Mit JavaScript hat es nichts zu tun. Hab es bei Epiphany grad mal 
abgeschaltet. Es kann eigentlich nur an den Cookies liegen

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was soll man denn noch alles aktivieren, ohne das all die Jahre auch so 
alles bestens funktioniert hat.

Btw:
Wenn ich das richtig verstanden habe, wird dieses "new" Flag nach dem 
lesen des Posts gelöscht. D.h. wenn man zur Übersicht zurück geht und 
man nochmal auf den Link klickt, dann ist man immer beim ersten Posting. 
Und wenn man das haben will, kann man doch gleich links in der Leiste 
auf das entsprechende Forum klicken und dann den Thread wählen. Da wird 
man ja auch zum ersten Post geleitet.

Also bitte, bitte lieber Andreas S. machs wieder so wie gehabt.

MfG

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wenn ich das richtig verstanden habe, wird dieses "new" Flag nach dem
>lesen des Posts gelöscht. D.h. wenn man zur Übersicht zurück geht und
>man nochmal auf den Link klickt, dann ist man immer beim ersten Posting.

Das ist richtig. Dann gibt es ja auch nicht neues mehr wo man mit "#new" 
hinspringen könnte. Erst wenn einer was neues postet wird der #new Anker 
wieder gesetzt (aber nur wenn das Cookie gespeichert wurde und die 
Webseite dadurch weiß wo du schon warst) und du springst da hin was eben 
neu ist.

Bei mir funktioniert das wunderbar und ich vermute bei den meisten 
anderen auch, sonst hätten sich schon viele beschwert das sie jetzt 
dauernd immer am Anfang landen und immer nach unten scrollen müssen.

Autor: Forumsleser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmmm,

ich lande immer am Anfang.
Und das man[n] nicht erkennt was ein neuer Thread ist....

So wie das jetzt ist, mags ich nicht.

MfG

Autor: James (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>ich lande immer am Anfang.
ich auch!

>So wie das jetzt ist, mags ich nicht.
ich auch nicht!

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bitte rückgängig machen.

Autor: Verständnisloser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kapier ich nicht. Funkt klasse bei mir. Wenn Andreas noch das einbaut 
das die Uhrzeit rot ist wenn etwas ungelesen ist dann ist es perfekt.

So wie es vorher war ist es so als würde jemand ein paar Seiten von 
einem Buch schreiben, die lest ihr dann, dann schreibt er weiter und ihr 
schlagt dann beim nächsten mal nur die letzte Seite auf weil ihr die 
Stelle nicht findet bei der ihr aufgehört habt zu lesen. Jetzt legt der 
Schreiber ein Lesezeichen in das Buch damit man an der Stelle 
weiterlesen kann an der man aufgehört hat

Ich würde mal sagen, Error in user.dll wenn das nicht funktioniert. An 
der Seite liegt es nicht

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und noch ein Nachteil, der mir gerade aufgefallen ist:
Selbst wenn das mit den Cookies bei mir funktionieren würde, sind die 
nur auf einem Rechner. Wenn man den Tag über also an verschiedenen 
Rechner sitzt, ist dieser "Lesezeichen"-Vorteil wieder hinfällig. Mit 
der alten Variante konnte man halt zum neuesten Post springen, egal an 
welchem Rechner man saß.

MfG,
Thomas

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann melde dich an, dann haste das Problem nicht

Autor: Ha Jo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein Firefox-Browser unter Windows merkt sich auch nur, dass ich 
angemeldet bin. Sonst nichts (wo ich schon war o.ä.). Habe zum Probiren 
mal alle Blocker abgeschaltet. Keine Änderung.

Mir gefällt das so auch garnicht.

Ich würde den News nicht eine solch große Fläche zur Verfügung stellen, 
die Listen mit de neueren Beiträgen dafür größer und zum Scrollen. 
Artikel genauso. Die News stehen da wochenlang und machen und brauchen 
Platz.

Hajo

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, schaut mal in ein Forum, zb Website. Da gibt es rechts eine Spalte 
mit dem Namen "Letzter Beitrag" mit einem Datum und einer Uhrzeit.

Sind die Zahlen bei euch da immer rot oder werden die schwarz nachdem 
ihr einen Beitrag gelesen haben?

Ich habe bei mir jetzt mal das Cookie "return_to" gelöscht und 
blockiert. Jetzt passiert bei mir das gleiche wie bei euch, nämlich das 
der Browser vergisst was ich schon gelesen hab und ich springe immer an 
den Anfang. Außerdem sind alle Zahlen rot.

Wenn ich das Cookie wieder akzeptiere und speichere ist die Welt wieder 
in Ordnung. Es ist alles nachvollziehbar, es liegt an euren 
Browserneinstellungen

Autor: Ha Jo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Jonas, Du bist ja ein ganz Schlauer. Damit Du mir glaubst, habe ich 
meine
Browsereinstellungen mal mit angehangen. Im nächsten Posting die
"Ausnahmen". Ansonsten sind alle Blocker abgeschaltet.
Und es funktioniert trotzdem nicht.

Hajo

Autor: Ha Jo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So hier der Rest.
Ich habe diese Einstellungen nur zum Ausprobieren so gesetzt.
Den Browser auch neu gestartet. Es geht nicht.

Sonst arbeite ich nicht mit diesen Einstellungen.

Hajo

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Einstellungen sehen bei mir identisch aus. Und die beiden besagten 
Cookies sind vorhanden. Wenn ich sie lösche, sind sie nach dem ersten 
Besuch der Seite wieder da. Trotzdem springt bei mir jeder Link zum 
ersten Posting.

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube euch ja das es bei euch nicht funktioniert. Es liebt aber 
nicht an der Webseite. Ich habe es jetzt mit verschiedenen Browsern 
versucht.

Firefox unter Linux und Windows (FF unter Linux auf 4 verschiedenen 
Rechnern)
IE6 unter Linux
Epiphany unter Linux
Galeon unter Linux
Opera unter Linux

Ich hab es sogar mit dem Browser Plugin von Eclipse probiert. Das hab 
ich überhaupt das erste mal angefasst

Überall funktioniert es bei mir. Bis auf die Firefox Browser sind alle 
in Ihrem Originalzustand. Bei Firefox installiere ich grundsätzlich 
verschiedene Plugins, u.a. Cookieculler.

Eine Frage habt Ihr mir noch nicht beantwortet. Wird bei Euch die Spalte 
"Letzter Beitrag" immer rot angezeigt oder werden die Zahlen schwarz 
nachdem Ihr ihn gelesen habt?

Autor: Hans Klock (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich finde es auch so wie es ursprünglich war viel besser.

Wenn man den Thread ja noch nicht gelesen hat, reicht ein drücken auf 
die "Pos1"-Taste und schon ist man am Anfang.

Autor: Ha Jo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jonas wrote:

>
> Eine Frage habt Ihr mir noch nicht beantwortet. Wird bei Euch die Spalte
> "Letzter Beitrag" immer rot angezeigt oder werden die Zahlen schwarz
> nachdem Ihr ihn gelesen habt?

Bei mir wird nichts rot angezeigt, auch nicht schwarz. Sieht mir eher 
nach sehr dunkel blau aus ;-)

Hajo

Autor: Jonas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>Wenn man den Thread ja noch nicht gelesen hat, reicht ein drücken auf
>die "Pos1"-Taste und schon ist man am Anfang.

Es geht weder darum an den Anfang zu kommen noch an's Ende. Es geht 
darum an die Stelle zu kommen an der man aufgehört hat mitzulesen. Dafür 
gibt es nunmal keine Taste

>Bei mir wird nichts rot angezeigt, auch nicht schwarz. Sieht mir eher
>nach sehr dunkel blau aus ;-)

Blau???? Siehe Anhang. So sollte das in etwa aussehen.

Autor: Ha Jo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja Guten Morgen Jonas.

Hast Du Dir den Titel dieses Threads mal genau durchgelesen?
Jetzt weiß ich, warum Du ROT siehst und andere (auch ich) nicht.
Man_o_man

Ich bleibe bei meiner Meinung, siehe
Beitrag "Re: Übersicht "Forum: Neue Beiträge" auf Startseite änder"

Hajo

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
NARF ich versuche Euch zu helfen den Fehler zu finden.

Mir ist schon klar worum es geht.

Ich wollte wissen ob bei Euch diese Anzeige nur rot dargestellt wird 
oder so wie auf dem Bild dargestellt. Wenn es bei euch nur rot ist dann 
hat es was mit den Cookies zu tun. Ich kann das hier bei jedem Browser 
manuell nachvollziehen.

Aber ich glaube euch ist nicht mehr zu helfen, also lass ich es besser.

@ Andreas: wie schon oben vorgeschlagen wäre es super wenn du die auf 
dem letzten Bild gezeigte Funktion noch auf die Startseite übertragen 
könntest. Dann wüsste man was neu ist und was nicht

Autor: Markus Burrer (Firma: Embedit Mikrocontrollertechnik) (_mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kaum ist man ein paar Tage nicht online, schon ist es gemacht. Toll :)

Aber den Vorschlag für die Ergänzung von weiter oben finde ich auch gut.

Fettes Mercy an Andreas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.