mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Pic 12F629 defekt?


Autor: Aspirin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich habe hier 2 x 12f629 pic die ich nicht mehr auslesen kann. 
Mein Brenner funktioniert allerdings ohne probleme. Da ich weitere 3 
habe die funktionieren. Kann man solche irgendwie reparieren oder eben 
wieder so machen das die funktionieren? Danke euch.

Hier mal aus dem Basic Fenster die Beschreibung was er mir ausspuckt:

US-Burn V1.8 a2
-- Windows NT/2000/XP
-- Version 5.1 Build 2600
-- Service Pack 2
-- PIC-database V.16 (30.01.2008)
-- small fonts
-- USB-DLL-Version : 00010000
-- 1 sprut-device(s) detected
-- Brenner8, Firmware V. 0.11
-- Ukor= 1,042
-- Vdd = 5,208
## NO HEX-file loaded

## this PIC-ID 0x0000 is not in database

Autor: Aspirin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kann mir niemand helfen? wäre euch sehr dankbar. hab den sprut 8 
nachgebaut und die anderen 3 erfolgreich geflasht. also der programmer 
geht zu 100%

Autor: Aspirin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schäm keiner ne ideee???

Autor: Uwe Nagel (ulegan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese PIC's haben zumindest vergessen, wie sie heissen. Das sollte beim 
normalen Betrieb/Programmieren nicht vorkommen.
Vielleicht kannst du deine Brennersoftware überreden, trotz der 
ungültigen PIC-ID zu brennen. Dann siehst Du, ob noch was geht. Aber 
wahrscheinlich sind sie tot.
Was macht dich zu 100% sicher, dass dein Brenner geht? Nur, dass ihn 3 
von 5 Prozessoren überlebt haben? Das könnte man auch als zu 60% gehen 
bezeichnen...

Autor: juppi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

Antwort ist für mich auch Interessant.

Habe einige welche mein Brenner nicht mehr erkennt.
Das alte Programm im Pic ist aber noch voll funktionsfähig.

MfG

Autor: Aspirin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, danke erst mal für die Antwort.
Was mich so sicher macht ist, dass ich drei mal Sprut Brenner 8 hier 
rumliegen habe und bei keiner diese zwei PICs erkannt werden. Die 
anderen drei PICs funktionieren einwandfrei. Wie kann ich es denn im 
US-Burn wählen das er mich trotzdem brennen lässt, da ja keine Funktion 
freigeschaltet wird, wenn keiner erkannt wird. Ich hoffe mir hilft 
jemand und wenn die TOT sind dann ab in den Müll, aber man soll ja nicht 
gleich aufgeben oder? :D DANKE!!!

Autor: Aspirin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kann sonst niemand helfen eine Seite würde auch langen, bei sprut hab 
ich nichts gefunden. Danke.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>kann sonst niemand helfen eine Seite würde auch langen, bei sprut hab
>ich nichts gefunden. Danke.

Was für eine Seite ? Wie repariere ich meinen PIC ?

Deine PICs sind scheinbar defekt. Jetzt musst du dich fragen
warum das so ist. Als erstes: Programmierspannung
möglicherweise zu hoch ?
Als zweites: VCC vieleicht zu hoch ?

Abblockkondensatoren nicht eingebaut ?
Programmierkabel zu lang ?

Ich hab schon recht lange mit PICs zu tun.
Die sind schon ziemlich robust.

Autor: Aspirin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok ich danke dir für deine Antwort dann hau ich die beiden jetzt einfach 
in Elektroschrott rein. Oder will die jemand haben? Ich will dann nur 
Porto dafür also fast geschenkt :D bis dann.

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Häng VPP auf separate 12V und verbinde auch die Massen.

Autor: Analog (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht hast Du die LV-Programming Fuse disabled, dann geht nur High 
Voltage Programming.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Analog

>Vielleicht hast Du die LV-Programming Fuse disabled, dann geht nur High
>Voltage Programming.

Bevor du hier weiter Schrott verbreitest informiere dich
erstmal. Die 12f629 Dinger haben keine LVP Fuse.

Autor: Aspirin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das heißt jetzt? was soll ich machen?

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
holger halt doch einfach mal die ....

ich hab mit 12V an VPP solche Dinger wieder zum Leben erweckt.

Autor: Aspirin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ihr seid mir zwei lustige :D entscheidet euch bitte mal bevor ich die 
weg haue. danke ^^

Autor: juppi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

alle eure vorschläge habe ich schon vor längerer zeit gemacht

erfolglos!

MfG

Autor: Aspirin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@juppi also kann ich die dinger weg hauen? danke.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.