www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik USBASP in windos 7 64bit


Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habt ihr mal probiert den USBASP unter Windows 64 zu installieren?
Bei mir wird er als unbekannt angezeit und ich kann die aktuelle Treiber 
für 64bit auch nicht installieren. Windows meint, dass dies nicht die 
richtigen seien.

In der Readme steht noch:
/*
For Windows Vista X64 and Windows 7 X64:

First enable the "testsigning" mode,
manually by selecting Start->All Programs->Accessories->Command Prompt,
right-clicking on it, selecting "Run as administrator"
and typing the following command:
>> bcdedit -set TESTSIGNING ON

To disable testsigning mode, you need to run the following command:
>> bcdedit -set TESTSIGNING OFF

Note that you will need to restart your computer for this change to take 
effect.
*/

Erstmal erkennt diese Befehl mein Windows gar nicht, aber durch F8 beim 
starten ging es schließlich.
Bringt aber nix es funktioniert immer noch nicht!
Wisst ihr noch was ich tuen könnte.
Probiere gerade ob es im XP Mode funktioniert, sieht aber schlecht aus..


Wünsche einen schönen Abend

Klaus

Autor: Jens L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi

habe das selbe Problem wie Klaus, er erkennt den usbasp einfach nur als 
unkown device und akzeptiert die treiber nicht.

Wäre schön wenn jemand ein Lösung wüsste.

Grüße Jens

Autor: andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,bei mir (Win 7 X 64) klappt es einwandfrei.
Beim Hochfahren nur jedesmal F8 drücken nervt schon.
gruss
andy

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: KeauHou (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst ein XP mit Virtualbox installieren. Darüber hast du im Gast 
auch zugriff auf USB Geräte auf dem Wirt. Funktioniert wunderbar.

Autor: klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, da ist es aber weniger umständlich den TESTSIGNING-Modus 
einzurichten.

Autor: Gerhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

das mit F8 beim Hochfahren lässt sich mit dem Tool
von dieser Seite erledigen
http://www.ngohq.com/home.php?page=dseo

Gruss gerhard

Autor: klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

obwohl das Thema scheinbar alt ist, war ich mit den angebotenen
Lösungswegen unzufrieden. Falls es noch nicht bekannt sein sollte, wird
die Lösung des Problems hier geschildert:
http://www.van-wees.eu/english/usbasp.html

Mit Hilfe fremder Treiber (Prüftechnik) benötigt man KEINEN Testsigning
Modus mehr. Auf meinem Win 7 x64 hat es wunderbar funktioniert. USBasp
wird erkannt und es läuft ohne zu meckern.

Am besten den oberen Link lesen. Bei Bedarf kann ich die modifizierte
.inf hochladen.

Gruß

Autor: Claudio H. (Firma: BLS-Electronics) (hedie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas schrieb:
> Am besten den oberen Link lesen. Bei Bedarf kann ich die modifizierte
> .inf hochladen.

Hallo

Ja es besteht bedarf :)

Vielen Dank :)

Autor: Oliver Ju. (skriptkiddy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Claudio Hediger schrieb:
> Ja es besteht bedarf :)

Am besten die aktuelle libusb für Windows herunterladen und mit dem 
Infwizard ein Treiberpaket erstellen. Ist sehr einfach zu 
bewerkstelligen.


Gruß Skriptkiddy

Autor: Claudio H. (Firma: BLS-Electronics) (hedie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe gerade das problem, das ich nicht weiss wohin das setup die 
treiber von Prüftechnik kopiert hat

Autor: Oliver Ju. (skriptkiddy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Claudio Hediger schrieb:
> ich habe gerade das problem, das ich nicht weiss wohin das setup die
> treiber von Prüftechnik kopiert hat
Das musst du mal genauer erklären.

Autor: Claudio H. (Firma: BLS-Electronics) (hedie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja die usbtreiber sind als setup in einer exe

und ich kann keinen pfad auswählen... das setup installiert den treiber 
und die inf irgendwo hin...

Autor: Claudio H. (Firma: BLS-Electronics) (hedie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich finde den treiber nicht...

Kann ihn mir vielleicht jemand zur verfügung stellen?

Vielen dank

Autor: Oliver Ju. (skriptkiddy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Claudio Hediger schrieb:
> Kann ihn mir vielleicht jemand zur verfügung stellen?

Wenn du einen Treiber für den usbasp brauchst, dann besorg dir die 
aktuelle libusb für Windows und erstelle dir mit dem darin entahltenen 
infwizard selber einen insallierbaren Treiber. Der funktioniert dann 
ohne irgendwelche Kopfstände und ohne Signatur-Probleme unter Windows7 
X64.

Was ist daran so schwer?
Findest du die libusb für Windows nicht?

Autor: Claudio H. (Firma: BLS-Electronics) (hedie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hat wunderbar geklappt! danke :)

Autor: Oliver Ju. (skriptkiddy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Claudio Hediger schrieb:
> hat wunderbar geklappt! danke :)

Siehste? War doch einfacher als du dachtest.

Gruß Skriptkiddy

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
leider ist de van-weeslink nicht mehr aktuell,
und auch ummer noch gibt es das usbasp Problem.
Desahlb können Sie mir den Inhalt nicht nochmal zuposten?
Danke

Oliver J. schrieb:
> Claudio Hediger schrieb:
>> hat wunderbar geklappt! danke :)
>
> Siehste? War doch einfacher als du dachtest.
>
> Gruß Skriptkiddy

Autor: Martin e. C. (eduardo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter schrieb:
> Hallo
> leider ist de van-weeslink nicht mehr aktuell,
> und auch ummer noch gibt es das usbasp Problem.
> Desahlb können Sie mir den Inhalt nicht nochmal zuposten?
> Danke

Das brauchst du nicht, du kannst den Treiber selber erstellen!

Oliver J. schrieb:
> Wenn du einen Treiber für den usbasp brauchst, dann besorg dir die
> aktuelle libusb für Windows und erstelle dir mit dem darin entahltenen
> infwizard selber einen insallierbaren Treiber. Der funktioniert dann
> ohne irgendwelche Kopfstände und ohne Signatur-Probleme unter Windows7
> X64.

Falls nicht klappt mede dich per PN.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.