mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik FT232 wird vom PC nur als "Unbekanntes Gerät" erkannt


Autor: Sebastian Ulmer (sulmer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,
meine Hardware verfügt über einen FT232BM. Wenn ich nun die USB 
Verbindung zum PC herstelle, wird der Chip als "Unbekanntes Gerät" 
erkannt.
Möchte ich den Treiber dann manuell über "Treiber aktualisieren" 
installieren, so bekomm ich die Meldung, das keine passende Software 
gefunden wurde und der Chip bleibt weiterhin als "Unbekanntes Gerät" im 
Gerätemanager.
Die Treiber stimmen aber, hab es mal mit einer älteren Hardware versucht 
und dort wird der Chip gleich erkannt.

Hab die Freds zu dem Thema hier durchgelesen aber leider nichts 
gefunden.

Bisher probiert:
-FT Clean
-Pegel am FT gemessen (müssten alle stimmen)
-Hardware auf Kurzschlüsse, Lötbrücken usw. gecheckt

Bisher leider ohne Erfolg.
Achja es ist kein EEPROM angeschlossen.

Der FT müsste doch von meinem PC erkannt werden, auch wenn mein uC auf 
der Hardware noch nicht initialisiert wurde oder?

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe zwar keine Erfahrungen mit den FTxxx-Schaltkreisen, aber der 
Effekt: "Unbekanntes Gerät gefunden" tritt auf, wenn irgendetwas an der 
USB-Schnittstelle hängt und Strom aufnimmt, aber kein Datenaustausch 
stattfindet. Guck mal die Data+ und Data- Leitungen, die zu dem FTxx 
gehen
nach. Es muß auch ein Ziehwiderstand von einer der Data-Leitungen nach 
+Ub
vorgesehen werden (ich glaube 1,5 Kiloohm), damirt der Rechner das Ding 
als USB 1 oder USB 2 gerät erkennt.

MfG Paul

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hardwareproblem.
D+ und D- wirklich nicht vertauscht und richtig angeschlossen? Reset des 
FT232 richtig angeschlossen? Ohne EEPROM sollte gehn, hab ich schon 
mehrmals gemacht. Quarz richtig angeschlossen? Richtige Frequenz 
genommen? Poste mal die Schaltung.

Autor: Sebastian Ulmer (sulmer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung ist im Geschäft, da komm ich erst am Montag wieder hin.
Dann werd ich mir D+ und D- nochmal genau anschaun und mich dann nochmal 
melden.

Autor: Udo S. (udo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

1. passenden Treiber von FTDI runterladen.
2. ohne USB-Verbindung zur Hardware den Treiber installieren.
3. ggf. PC neu booten.
4. USB-Verbindung zur Hardware herstellen.

Der FT232 wird als virtueller COM-Port erkannt.

Gruß
Udo

Autor: Bluze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nach Verwendung von FT-Clean Windows neustarten!
 Dann erst wieder neuen Treiber installieren. (hat bei mir geholfen)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.